HDOJ What Are You Talking About

 

What Are You Talking About

http://acm.hdu.edu.cn/diy/contest_showproblem.php?cid=12654&pid=1004

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 102400/204800K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i'm from mars.
i like earth!

Hint

Huge input, scanf is recommended.

Author

Ignatius.L
 
一开始这个题老是RE ,参考大牛的代码后恍然大悟,原来啊
 

#include<iostream>
#include<cstring>
using namespace std;
struct trie{ 
       struct trie *child[26];
       char Engword[11];  //存放英语单词
       trie(){  //初始化
          for(int i=0;i<26;i++)
             child[i]=NULL;
           Engword[0]='\0';      
       }
};
struct trie *root;
void insert(char eng[],char mar[]){  
     int i,len;
     struct trie *current=root,*newnode;
     len=strlen(mar);
     if(len==0)  return ;
     for(i=0;i<len;i++){
           if(current->child[mar[i]-'a']!=NULL)
                 current=current->child[mar[i]-'a'];
           else{
                newnode=new trie;
                current->child[mar[i]-'a']=newnode; 
                current=newnode;
                }    
           }
     strcpy(current->Engword,eng);//把英语单词插入到火星文的最后一个节点
}
char *find(char *source){
     int i,len;
     len=strlen(source); 
     if(len==0)  return NULL;
     struct trie *current=root;
     for(i=0;i<len;i++){
          if(current->child[source[i]-'a']!=NULL) 
                current=current->child[source[i]-'a'];
          else
              return NULL;                  
     }
     if(strcmp(current->Engword,"")!=0)//不等于NULL
          return current->Engword;      
     return NULL;
}
int main(){
    char a[11],b[11];
    root=new trie;
    scanf("%s",a); //吞掉"START"
    while(scanf("%s",a) && strcmp(a,"END")!=0){
           scanf("%s",b);
           insert(a,b);                       
    }
    scanf("%s",a); //"START"
    getchar();  //注意吞掉回车符
    char temp[3005];
    while(1){
           gets(temp);
           if(strcmp(temp,"END")==0) //结束条件 
                   break;
           int i,len,k=0;   
           len=strlen(temp);
           temp[len]=' ';  //多加一个空格,否则无法输出最后一个单词
           temp[++len]='\0';  
           char p[3005];  
           for(i=0;i<len;i++){
                 if(!(temp[i]>='a' && temp[i]<='z') ){ //不是小写字母
                        p[k]='\0';
                        char *t=find(p); //查找
                        if(t)  //如果存在就输出英语
                             printf("%s",t);
                        else    //不存在就原样输出火星文
                            printf("%s",p);
                         k=0; //注意恢复 k为 0
                         if(i!=len-1) //最后一个是多余的空格
                              printf("%c",temp[i]);//输出非小写字母字符(标点)
                
                      }
                 else
                    p[k++]=temp[i];                        
           } 
           printf("\n");         
    }
  //  system("pause");
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值