06-图2 Saving James Bond - Easy Version(25 分)---DFS

06-图2 Saving James Bond - Easy Version(25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integersN (100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No


题意分析:

  一个人被困在孤岛上,岛被水环绕着,水中有鳄鱼,给出鳄鱼的坐标,人一次能跳的距离,用鳄鱼做跳板,问最后能否上岸。和去年校赛的题有点类似,明天校赛不要太惨烈呀~。

标准的DFS!需要找出若干个第一跳!依次进行DFS.


#include<iostream>
#include<cstdio>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;

#define minl 42.5

struct point {
	int x, y;
	bool vis;
};
int N, D;
vector<point>s;  
point o;
int flag;//是否能跳出去
double Distance(point a, point b)
{
	return sqrt(pow(a.x - b.x, 2) + pow(a.y - b.y, 2));
}

void dfs(int i)
{

	s[i].vis = true;
	if (50 - abs(s[i].x) <= D || (50 - abs(s[i].y) <= D))
		flag = 1;
	
	for (int j = 0; j < N; j++)
		if (!s[j].vis&&Distance(s[i], s[j]) <= D)
			dfs(j);	
}

int main()
{
	flag = 0;
	int i;	
	point p;
	vector<int>firstjump;
	cin >> N >> D;
	for (int i = 0; i < N; i++)
	{
		cin >> p.x >> p.y;
		p.vis = false;
		s.push_back(p);
	}
	if (D >= minl) { cout << "Yes" << endl; return 0; }//直接飞出去啦
	for (int i = 0; i < N; i++)
		if (Distance(s[i], o) <= D + 7.5)
			firstjump.push_back(i);
	if (firstjump.empty()) { cout << "No" << endl; return 0; }//第一跳都没有
	for (int i = 0; i < firstjump.size(); i++)dfs(firstjump[i]);
	if(flag)		cout << "Yes" << endl;
	else cout << "No" << endl;
	system("pause");
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值