hdu-1016Prime Ring Problem(素数环 dfs)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41672    Accepted Submission(s): 18445


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 


题目大意是相邻两个元素和为素数  数是20以内的 所以只要判断40以内的数是不是素数并且保存即可


#include<iostream>
#include<cstring>
#include<string>
using namespace std;
bool vis[25],prime[45];
static int j=1;
int a[25];
int n;
int is_prime(int m)
{
    if(m==1)return 0;
    for(int i=2;i*i<=m;i++)
    {
        if(m%i==0)return 0;
    }
    return 1;
}
void dfs(int cre)
{
    if(cre==n&&prime[a[n-1]+a[0]])
    {
        for(int i=0;i<n;i++)
        {
            cout<<a[i];
            if(i<n-1)
            cout<<" ";
            else cout<<endl;
        }
    }else for(int i=2;i<=n;i++)
    {
        if((!vis[i])&&prime[i+a[cre-1]])
        {
            a[cre]=i;
            vis[i]=1;
            dfs(cre+1);
            vis[i]=0;
        }
    }
}
int main()
{
    
    memset(prime,0,sizeof(prime));
    for(int i=1;i<=42;i++)
    {
        prime[i]=is_prime(i);
    }
    while(cin>>n)
    {         
    memset(vis,0,sizeof(vis));
    memset(a,0,sizeof(a));
        a[0]=1;
        //a[0]=1;
        cout<<"Case "<<j++<<":"<<endl;
        dfs(1);
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值