HDU 1016 素数环 dfs搜索

26 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1016

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题目大意:1-n的n个数字构成素数环,每相邻两个数之和为素数。要求数字1必须放在第一位。

思路:也是紫书上的题目。用dfs搜索就可以了。看n的范围在20以内,可以预处理出来前100的素数。函数solve(cur)表示选取第cur个数字,我们进行n次试探,已经用过的不选,可以选的但是这个数字和第cur-1个数字之和不是素数的也不选。注意选第n-1个数字的时候除了要和n-2个判断,也要和第1个判断。(环状)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

int flag[100];
int vis[25];
int a[25];
int n;
void solve(int cur);

int main()
{
	for(int i=2;i<=sqrt(100+0.5);i++)
		if(!flag[i])
			for(int j=i*i;j<=100;j+=i)
				flag[j]=1;
	int t=0;
	while(~scanf("%d",&n))
	{
		printf("Case %d:\n",++t);
		memset(vis,0,sizeof(vis));
		memset(a,0,sizeof(a));
		vis[1]=1;
		a[1]=1;
		solve(2);
		printf("\n");
	}
	return 0;
}

void solve(int cur)
{
	if(cur>n&&n>1&&!flag[a[n]+a[1]])
	{
		printf("%d",a[1]);
		for(int i=2;i<=n;i++)
			printf(" %d",a[i]);
		printf("\n");
		return ;
	}
	for(int i=2;i<=n;i++)
	{
		if(vis[i])
			continue;
		if(flag[(a[cur-1]+i)])//已经放过 或者和不为素数
			continue;
		a[cur]=i;
		vis[i]=1;
		solve(cur+1);
		vis[i]=0;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值