poj 3735 Training little cats

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:g i : Let the ith cat take a peanut.e i : Let the ith cat eat all peanuts it have.s i j : Let the ith cat and jth cat exchange their peanuts.All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

Source

题目大意 n只猫,三种关于花生的命令 (得花生,吃花生,交换花生),给出一套命令,重复n次,问最后每只喵呜得到多少花生。
思路矩阵快速幂构造加矩阵乘法优化,网上题解很多自己去看...
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=105;
typedef long long LL;
int N; 
struct Matrix
{
	LL matrix[maxn][maxn];
	Matrix()
	{
		memset(matrix,0,sizeof(matrix)); 
	}
	void init()
	{
		for(int i=0;i<maxn;i++)matrix[i][i]=1;
	}
};
Matrix matrixmul(Matrix a,Matrix b)
{
	Matrix ans;
	for(int i=0;i<N;i++)
	{
		for(int k=0;k<N;k++)
		{
			if(!a.matrix[i][k])continue;
			for(int j=0;j<N;j++)
			{
				ans.matrix[i][j]+=a.matrix[i][k]*b.matrix[k][j];
			}
		}
	}
	return ans;
} 
Matrix matrixquickpow(Matrix a,int b)
{
	Matrix ans;
	ans.init();
	while(b)
	{
		if(b&1)ans=matrixmul(ans,a);
		b>>=1;
		a=matrixmul(a,a);
	}
	return ans;
}
int main()
{
	int n,m,k,x,y;
	char s;
	while(scanf("%d%d%d",&n,&k,&m)==3&&(m||n||k)) 
	{
		Matrix mtr;
		mtr.init();
		N=n+1;
		int cas=1;
		while(m--)
		{
			cin>>s;
			if(s=='g')
			{
				scanf("%d",&x);
				mtr.matrix[x-1][n]++;
			}
			else if(s=='e')
			{
				scanf("%d",&x);
				for(int i=0;i<=n;i++)mtr.matrix[x-1][i]=0;
			}
			else if(s=='s')
			{
				scanf("%d%d",&x,&y);
				for(int i=0;i<=n;i++)swap(mtr.matrix[x-1][i],mtr.matrix[y-1][i]);
			}
		}
		Matrix ans=matrixquickpow(mtr,k);
		for(int i=0;i<n;i++)
		{
			if(i==0)printf("%I64d",ans.matrix[i][n]);
			else printf(" %I64d",ans.matrix[i][n]);
		}
		printf("\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值