DNA Sorting

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42532 Accepted: 16513

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

解题思路:
      使用STL编程,根据需求建立结构体DNA,string DNA序列,long number 是DNA序列中的逆序数。使用vector,并使用排序函数sort。
代码如下:

#include <iostream>
#include <string>
#include <fstream>
#include <vector>
#include <algorithm>
using namespace std;
struct DNA
{
 string str;
 long int number;
};
bool myComp( const DNA &d1, const DNA &d2 )
{
 if(d1.number!=d2.number)
  return d1.number<d2.number;
 else
  return d1.str<d2.str;
}
// 计算逆序数
long int calNumber( char ch[], int n )
{
 long int count=0;
 int i,j;
 for( i=0; i<n-1; i++ )
  for( j=i+1; j<n; j++ )
  {
   if( ch[i]>ch[j] )
   {
    count++;
   }
  }
 return count;
}
int main()
{
// ifstream cin("test.txt");
 vector<DNA> dna;
 int n,m;
 char ch[51];
 int i;
 cin>> n>>m ;
 dna.clear();
 cin.getline(ch,51,'/n'); 
 for( i=0; i<m; i++ )
 {
  cin.getline(ch,51,'/n'); 
  DNA nd;
  nd.number=calNumber(ch,n);
  nd.str = ch;
  dna.push_back(nd);
 }
 sort(dna.begin(), dna.end(),myComp);
 vector<DNA>::iterator it;
 for(it=dna.begin(); it!=dna.end(); it++ )
 {
  cout<<(*it).str<<endl;
 }
 return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值