Square hdu 1518

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5695    Accepted Submission(s): 1804


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source
 

Recommend
LL
 



思路:DFS+剪枝

DFS刚接触有点搞不透 啊,参考别人代码写的。

#include<iostream>
using namespace std;
#define max(a,b) a>b? a:b
int a[23],n,sum,aver,maxn;
bool b[23],flag;
void dfs(int s,int cnt,int j)
{
    if(s==aver)
    {
        cnt++;
        if(cnt==4)
        {
            flag=true;
            return ;
        }
        else
        s=0;
        j=0;
    }
    if(flag)return ;
    for(int i=j;i<n;i++)
    {
        if(!b[i]&&s+a[i]<=aver)
        {
            b[i]=true;
            dfs(s+a[i],cnt,i);
            b[i]=false;
        }
    }
}
int main()
{
    int t,i;
    cin>>t;
    while(t--)
    {
        cin>>n;
        sum=maxn=0;
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            sum=sum+a[i];
            maxn=max(a[i],maxn);
            b[i]=false;
        }
        if(sum%4!=0||maxn>sum/4)
        cout<<"no"<<endl;
        else
        {
            flag=false;
            aver=sum/4;
            dfs(0,0,0);
            if(flag)
            cout<<"yes"<<endl;
            else
            cout<<"no"<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值