Square
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 13645 Accepted Submission(s): 4324
Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
Sample Output
yes no yes
Source
Recommend
题意大概就是给你几个数代表棍的长度,让你判断他能不能构成正方形(标准的),我用的是深度搜索,一遍遍搜索,用now作为判断搜索的第几次,然后超时了,上网上看了看大神的代码,他加了个index,用来降低时间复杂度,
index的大体意思是:每一遍扫描代表扫出来一条边,所以只能往前走,不会拐过来在用以前的数值的,所以扫描过的没必要在扫描一遍了。还有flag全局变量判断及在dfs中的剪纸,我这里简单说一下,第一个if是因为判断到第五条边了,然后四条就够,所以结束,把flag赋值为1。dfs中的第二个if里面有个判断flag的,就是第五条边都出来了,下面的就不用再去计算了。dfs for循环里面的flag判断也是类似。这样剪完之后就可以过了~~~
#include <stdio.h>
int save[25];
int vis[25];
int m,len,flag;
void dfs(int now,int l,int index)
{
int i;
if(now==5)
{
flag=1;
return ;
}
if(l==len)
{
dfs(now+1,0,0);
if(flag)
return ;
}
for(i=index;i<m;i++)
{
if(!vis[i]&&(save[i]+l)<=len)
{
vis[i]=1;
dfs(now,save[i]+l,i+1);
if(flag)
return ;
vis[i]=0;
}
}
}
int main()
{
int t,i,j,sum;
scanf("%d",&t);
while(t--)
{
scanf("%d",&m);
sum=0;
for(i=0;i<m;i++)
{
scanf("%d",&save[i]);
sum+=save[i];
}
if(sum%4)
{
printf("no\n");
continue;
}
len=sum/4;
for(i=0;i<m;i++)
{
if(len < save[i])
break;
}
if(i<m)
{
printf("no\n");//如果有一个比边长大,则不符合
continue;
}
for(i=0;i<25;i++)
{
vis[i]=0;
}
flag=0;
dfs(1,0,0);
if(flag)
{
printf("yes\n");
}
else
{
printf("no\n");
}
}
return 0;
}
题意大概就是给你几个数代表棍的长度,让你判断他能不能构成正方形(标准的),我用的是深度搜索,一遍遍搜索,用now作为判断搜索的第几次,然后超时了,上网上看了看大神的代码,他加了个index,用来降低时间复杂度,
index的大体意思是:每一遍扫描代表扫出来一条边,所以只能往前走,不会拐过来在用以前的数值的,所以扫描过的没必要在扫描一遍了。还有flag全局变量判断及在dfs中的剪纸,我这里简单说一下,第一个if是因为判断到第五条边了,然后四条就够,所以结束,把flag赋值为1。dfs中的第二个if里面有个判断flag的,就是第五条边都出来了,下面的就不用再去计算了。dfs for循环里面的flag判断也是类似。这样剪完之后就可以过了~~~