POJ 1001(Exponentiation)



Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 79498 Accepted: 18840

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 
答案:

#include <stdio.h>
#include <string.h>

int result[126] = {0};//5 * 25 = 125
int len;
void mul (int a[], int n) {
	int i ;
	int add = 0;//相乘后增加的
	for ( i = 0; i < len; i++) {
		int term = a[i] * n + add;
		a[i] = term % 10;
		add = term / 10;
	}
	while (add) {
		a[i++] = add % 10;
		add = add / 10;
	}
	len = i;//长度可能有变化
}
int main () {
	char a[6];
	int a1, r;
	while (scanf("%s %d", a, &r) != EOF) {
		int position = 0, sum = 0, len1;//position记录小数点的位置
		len1 = strlen(a);
		for ( int i = 0; i < len1; i++) {//将浮点数转化为整数
			if (a[i] == '.') {
				position = (len1 - i - 1) * r;
					i++;	
			}
			sum = sum * 10 + a[i] - 48;
		}
		result[0] = 1;
		len =  1;
		for (int i = 0; i < r; i++) {
			mul(result, sum);
		}
		//增加小数点
		if (len <= position) {
			printf(".");
			//补零
			for (int i = 0; i < position - len; i++) {
				printf("0");
			}
			int k = 0;
			//去掉无效0
			while (result[k] == 0) {
				k++;
			}
			for (int i = len - 1; i >= k; i--) 
				printf("%d", result[i]);
			printf("\n");
		}
		else {
			int j = 0;
			// 去掉无效0
			while (result[j] == 0 && j < position) 
				j++;
			for (int i = len - 1; i >= j; i--) {
				if (i + 1 == position)
					printf(".");
				printf("%d", result[i]);
			}
			printf("\n");
		}
	}
}

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 79498 Accepted: 18840

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值