CentOS 8安装Docker报错(Problem: package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.)

CentOS8安装docker和docer-conpose

报错如下
Problem: package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed

不废话,直接上步骤

1、yum更新

yum update

uodatte
2、安装依赖环境

yum install -y yum-utils device-mapper-persistent-data lvm2

yillia

3、添加docker源

yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo

docker
4、安装docker-ce

yum install  docker-ce

error
Error:
Problem: package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed

此时需要安装新版containerd.io

dnf install https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm

containerd
4、再次安装docker-ce

yum install  docker-ce 

ce
此时查看docker版本

docker -v

v
5、直接拉取github上docker-compose

curl -L https://github.com/docker/compose/releases/download/1.24.0-rc1/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose

在这里插入图片描述
6、赋权限

 chmod +x /usr/local/bin/docker-compose
 

在这里插入图片描述
安装完成,查看版本

docker-compose --version

在这里插入图片描述

请开始CENTOS 8 下 DOCKER之旅~

©️2020 CSDN 皮肤主题: 黑客帝国 设计师: 上身试试 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值