POJ 1862 Stripies(G++与C++的抉择)

Time Limit: 1000MS Memory Limit: 30000KB 64bit IO Format: %lld & %llu

 Status

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

题意:即给你一定的生物,他们会有一定的重量,如果他们相互碰撞,    那么根据题目给的那个公式2*sqrt(m1*m2) ,质量会减少。             这个公式表示的是两个细菌质量分别为m1和m2,而他们碰撞后的总质量会变为2*sqrt(m1*m2)             

            给你一定的这样的生物及它们的质量,要你求它们经过碰撞后的最小总质量。             

            容易看出,所有的生物全部相撞了后,肯定可以得到一个总质量             

            但是如果排列碰撞的顺序,使得最后的总质量最小呢???

            把大数尽可能多的参与开方运算,这样可以保证得到的数最小。

            其中需要注意的一点是当只有一个细菌时不发生碰撞,还是原来的质量,当有n个细菌时,只能进行n-1次碰撞。

            PS:这道题WA了好几次,一直找不到错误,最后还是听别人说G++提交不能用double,你要是想用G++提交就改成float,一改直接AC,很气。。。。。我又测试了一下原来用double的代码,用C++提交直接过了。我以前看博客时也注意到有人说G++优化不如C++好,有的代码用G++提交会超时,C++提交就没有问题,可能真的是G++优化不如C++吧。以后吸取教训~~~~(>_<)~~~~


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node
{
    int  w;
} a[110];
bool cmp (node A,node B)
{
    return A.w>B.w;
}
int main()
{
    int n,i,j;
    double sum;
    while(~scanf("%d",&n))
    {
        for(i=0; i<n; i++)
            scanf("%d",&a[i].w);
        sort(a,a+n,cmp);
        sum=a[0].w;
        for(i=1; i<n; i++)
        {
            if(i!=1)sum=2*(float)sqrt(a[i].w*sum);

            else sum=2*(float)sqrt(a[i].w*a[i-1].w);
        }
        printf("%.3f\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值