HDU 1423 Greatest Common Increasing Subsequence(单调递增公共子序列)

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6831    Accepted Submission(s): 2216


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2

  大致题意就是让求两个数列的最长公共递增子序列。一个简单的dp。比最长公共子序列多了一个条件就是要求要递增,加一个判断条件(a[i]>b[j]&&dp[j]>maxx) 就行了。


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int a[510],b[510],dp[510];
int main ()
{
    int i ,j, n,m,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
            scanf("%d",&m);
        for(i=1; i<=m; i++)
            scanf("%d",&b[i]);
          int MAX=0,maxx;
          for(i=1;i<=n;i++)
          {
              maxx=0;
              for(j=1;j<=m;j++)
              {
                  if(a[i]>b[j]&&dp[j]>maxx)
                    maxx=dp[j];
                  if(a[i]==b[j])
                    dp[j]=maxx+1;
              }
          }
          for(j=1;j<=m;j++)
            if(dp[j]>MAX)  MAX=dp[j];
          printf("%d\n",MAX);
          if(t) printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值