UVA 133 The Dole Queue(救济金发放)

题目描述

为了缩短领救济品的队伍,NNGLRP决定了以下策略:每天所有来申请救济品的人会被放在一个大圆圈,面朝里面。选定一个人为编号 1 号,其他的就从那个人开始逆时针开始编号直到 N。一个官员一开始逆时针数,数 k 个申请者,然后另一个官员第 N 个始顺时针方向数 m 个申请者,这两个人就被送去再教育。如果两个官员数的是同一个人,那个人则被送去从政,然后2个官员再在剩下的人里面继续选直到没人剩下来,注意两个被选 中的人是同时走掉的,所以就有可能两个官员选中一个人。

Input

输入含有多组测试资料,每组测试资料一列含有三个数 N,k 和 m(k, m > 0,0<N<20)。 当输入为 0 0 0 代表输入结束。

Output

对每组测试资料输出一列。输出被选中的申请者的编号顺序(一对一对的)。每个数的宽度为 3 。每一对前面的那个编号为逆时针数的官员选出的,后面的那个编号为顺时针数的官员选出的(但是如果这2个官员选出同一个人,那就只会有一个编号)。每一对 之间以逗号分开。格式请参考Sample Output。

Sample Input

10 4 3 
13 17 42
7 8 47 
0 0 0 

Sample Output

 4 8, 9 5, 3 1, 2 6, 10, 7 
 4 11, 10 1, 8 6, 13 7, 3, 5 12, 9 2 
 1 3, 5 7, 2 4, 6

  • 题目描述:
  • n(n < 20)个人站成一圈,逆时针编号为1~n,有两个官员,A从1开始逆时针数,B从n开始顺时针数,在每一轮中,官员A数k个就停下来,官员B数m个就停下来
  • (注意有可能两个官员停在同一个人身上)。接下来被官员选中的人(1个或者两个)离开队伍
  • 输入n,k,m输出每轮里被选中的人的编号,如果有两个人,先输出被A选中的,
  • 例如,n = 10;k = 4; m = 3 输出为4 8,9 5,3 1,2 6,10,7。 输出的每个数应当恰好占3列
  • 题目分析:
  • ①用一个大小为0的数组表示人站成的圈
  • ②用0表示离开队伍的人,数数时候跳过就可以了。
  • ③这里最关键的问题就是如何统计官员AB数数选人的过程,所以这里考虑用两个p1、p2来指向他们的位置
  • ④顺时针和逆时针数数唯一的区别在于下标是加1还是减1,我们可以考虑把这两个过程融合到一个过程中,顺时针、逆时针我们看作一个+1/-1抽象为步长参数。
  • ⑤难点就在这里了,我们如何初始化p1、p2,怎么合理把他们融合起来p=(p+d+n-1)%n + 1 (这个很关键)
  • 循环过程:
  • 官员A:
    t = 4 -> p = 10 -> d = 1
    t = 3 -> p = 1 -> a[p] = 1
    t = 2 -> p = 2 -> a[p] = 2
    t = 1 -> p = 3 -> a[p] = 3
    t = 0 -> p = 4 -> a[p] = 4
    官员B:
    t = 3 -> p = 1 -> d = -1
    t = 2 -> p = 10 -> a[p] = 10
    t = 1 -> p = 9 -> a[p] = 9
    t = 0 -> p = 8 -> a[p] = 8
    官员A:
    t = 4 -> p = 4 -> d = 1
    t = 3 -> p = 5 -> a[p] = 5
    t = 2 -> p = 6 -> a[p] = 6
    t = 1 -> p = 7 -> a[p] = 7
    t = 0 -> p = 8 -> a[p] = 0 -> p = 9
  • ⑥这题还有一个关键点,就是输出格式的问题,因为每次循环情况有","隔开,最后一个没有逗号,所以我们要加一个变量left标示符,含义就是剩下的人数
  • ======================================================================================
  • 参考代码:

#include<stdio.h>
#include<string.h>
int book[21];
int n,k,m;
     //起始点为p,逆时针走t步,步长是d,
int go(int p,int d,int t)
{
    while(t--)
    {
        do
        {
            p=(p+d+n-1)%n+1;//这个不好想,跟初始化有关
        }
        while(book[p]==0);  //走到下一个非0数字
    }
     return p;
}
int main()
{
    while(scanf("%d%d%d",&n,&k,&m)&&n)
    {
        for( int i=1; i<=n; i++)
            book[i]=i;
        int left=n;//剩余的人数
        int p1=n,p2=1;
        while(left)
        {
            p1=go(p1,1,k);
            p2=go(p2,-1,m);
            if(p1==p2)//两个官员数到同一人
            {
                printf("%3d",p1);
                left--;
            }
            else//数到不同人
            {
                printf("%3d%3d",p1,p2);
                left-=2;
            }
            book[p1]=book[p2]=0;
            if(left) printf(",");//最后一个没有逗号,切记
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
用C++编写程序,实现以下问题2、题目ID Codes(POJ1146) Time Limit: 1000MS Memory Limit: 10000K 描述: It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set. For example, suppose it is decided that a code will contain exactly 3 occurrences of a', 2 of b' and 1 of c', then three of the allowable 60 codes under these conditions are: abaabc abaacb ababac These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message No Successor' if the given code is the last in the sequence for that set of characters. 输入: Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #. 输出: Output will consist of one line for each code read containing the successor code or the words 'No Successor'. 样例输入 abaacb cbbaa # 样例输出 ababac No Successor
05-22

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值