ACM-ICPC 2018 徐州赛区网络预赛H题

Ryuji is not a good student, and he doesn't want to study. But there are n books he should learn, each book has its knowledge a[i]a[i].

Unfortunately, the longer he learns, the fewer he gets.

That means, if he reads books from ll to rr, he will get a[l] \times L + a[l+1] \times (L-1) + \cdots + a[r-1] \times 2 + a[r]a[l]×L+a[l+1]×(L−1)+⋯+a[r−1]×2+a[r] (LL is the length of [ ll, rr ] that equals to r - l + 1r−l+1).

Now Ryuji has qq questions, you should answer him:

11. If the question type is 11, you should answer how much knowledge he will get after he reads books [ ll, rr ].

22. If the question type is 22, Ryuji will change the ith book's knowledge to a new value.

Input

First line contains two integers nn and qq (nn, q \le 100000q≤100000).

The next line contains n integers represent a[i]( a[i] \le 1e9)a[i](a[i]≤1e9) .

Then in next qq line each line contains three integers aa, bb, cc, if a = 1a=1, it means question type is 11, and bb, ccrepresents [ ll , rr ]. if a = 2a=2 , it means question type is 22 , and bb, cc means Ryuji changes the bth book' knowledge to cc

Output

For each question, output one line with one integer represent the answer.

样例输入复制

5 3
1 2 3 4 5
1 1 3
2 5 0
1 4 5

样例输出复制

10
8

分析:虽说是一个线段树(或树状数组)裸题,可比赛时还是想了好久,关键是怎么变形,所求式子可以化为\sum_{i=l}^{r}(r+1-i)*a[i]

,进一步化为\sum_{i=l}^{r}(r+1)*a[i]- \sum_{i=l}^{r}(i*a[i]),故维护两个树状数组即可

树状数组ac code:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+3;
ll c1[maxn],c2[maxn];
int n;
ll lowbit(ll x)
{
    return x&(-x);
}
ll getsum(ll c[],ll x)
{
    ll ans=0;
    while(x)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
void update(ll c[],ll x,ll val)
{
    while(x<=n)
    {
        c[x]+=val;
        x+=lowbit(x);
    }
}
int main()
{
    int q;
    ll val;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
    {
        scanf("%lld",&val);
        update(c1,i,val);
        update(c2,i,val*i);
    }
    ll l,r,op;
    while(q--)
    {
        scanf("%lld%lld%lld",&op,&l,&r);///注意l,r可能爆int
        if(op==1)
            printf("%lld\n",(r+1)*(getsum(c1,r)-getsum(c1,l-1))-getsum(c2,r)+getsum(c2,l-1));
        else if(op==2)
        {
           ll x=getsum(c1,l)-getsum(c1,l-1);
           update(c1,l,r-x);
           x=getsum(c2,l)-getsum(c2,l-1);
           update(c2,l,l*r-x);
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值