Stealing Harry Potter's Precious (bfs)

Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below: 



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

Input

  There are several test cases. 
  In each test cases: 
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100). 
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move. 
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank. 
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y). 
  The input ends with N = 0 and M = 0 

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1. 

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0

Sample Output

-1
5 

分析:本题是指定了搜索点的bfs,但最多只有4个点被指定了,所以可以枚举4个点的搜索顺序,有24种情况,时间复杂度24*100*100

ac code:

#include<bits/stdc++.h>
using namespace std;
int n,m;
const int maxn=200;
char s[105][105];
int px[4]= {0,0,1,-1};
int py[4]= {1,-1,0,0};
bool vis[105][105];
int path[105][105];
const int inf=0x3f3f3f3f;
struct node
{
    int x,y,s;
    node(int x,int y,int s):x(x),y(y),s(s) {}
    node() {}
};
bool check(int x,int y)
{
    if(s[x][y]=='#') return false;
    if(vis[x][y]) return false;
    if(x<1||x>n||y<1||y>m) return false;
    return true;
}
int bfs(int sx,int sy,int ex,int ey)
{
    memset(vis,0,sizeof vis);
    queue<node>q;
    while(!q.empty()) q.pop();
    q.push({sx,sy,0});
    vis[sx][sy]=1;
    int tx,ty;
    while(!q.empty())
    {
        node cur=q.front();
        q.pop();
        if(cur.x==ex&&cur.y==ey)
            return cur.s;
        for(int i=0; i<4; i++)
        {
            tx=cur.x+px[i];
            ty=cur.y+py[i];
            if(check(tx,ty))
                q.push({tx,ty,cur.s+1}),vis[tx][ty]=1;
        }
    }
    return -1;
}
bool book[10];
int k,x[5],y[5];
int _min;
void dfs(int cnt,int pre,int sum)
{
    if(cnt==k)
    {
        _min=min(_min,sum);
        return;
    }
    for(int i=1; i<=k; i++)
    {
        if(!book[i])
        {
            book[i]=1;
            dfs(cnt+1,i,sum+bfs(x[pre],y[pre],x[i],y[i]));
            book[i]=0;
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        memset(book,0,sizeof book);
        for(int i=1; i<=n; i++)
            scanf("%s",(s[i]+1));
        bool flag=0;
        int sx,sy;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
                if(s[i][j]=='@')
                {
                    sx=i,sy=j;
                    flag=1;
                    break;
                }
            if(flag) break;
        }
        flag=0;
        scanf("%d",&k);
        for(int i=1; i<=k; i++)
            scanf("%d%d",&x[i],&y[i]);
        x[0]=sx,y[0]=sy;
        for(int i=1; i<=k; i++)
            if(bfs(sx,sy,x[i],y[i])==-1) flag=1;
        if(flag)
        {
            puts("-1");
            continue;
        }
        _min=inf;
        dfs(0,0,0);
        printf("%d\n",_min);
    }
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值