HDU - 1757 A Simple Math Problem(基础矩阵快速幂)

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7158    Accepted Submission(s): 4373

题目描述:

Problem Description

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input

The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.

Output

For each case, output f(k) % m in one line.

Sample Input

10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0

Sample Output

45 104


矩阵快速幂裸题,初始矩阵为(9,8,7,6,5,4,3,2,1,0)T,相乘矩阵为

1 1 1 1 1 1 1 1 1 1

1 0 0 0 0 0 0 0 0 0

0 1 0 0 0 0 0 0 0 0

0 0 1 0 0 0 0 0 0 0

0 0 0 1 0 0 0 0 0 0

0 0 0 0 1 0 0 0 0 0

0 0 0 0 0 1 0 0 0 0

0 0 0 0 0 0 1 0 0 0

0 0 0 0 0 0 0 1 0 0

0 0 0 0 0 0 0 0 1 0


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>

#define ll long long
using namespace std;

const ll mod = 1e9 + 7;
ll num[16];
ll m, k;
struct Matrix
{
    ll m[16][16];
    Matrix()
    {
        memset(m, 0, sizeof m);
    }
};

Matrix pow(Matrix a, Matrix b)
{
    Matrix c;
    for(int i = 1; i < 11; i++)
    {
        for(int j = 1; j < 11; j++)
        {
            for(int k = 1; k < 11; k++)
            {
                c.m[i][j] += a.m[i][k] * b.m[k][j];
                c.m[i][j] %= m;
            }
        }
    }
    return c;
}

Matrix pow_matrix(Matrix a, ll n)
{
    Matrix b;
    for(int i = 1; i <= 10; i++)
    {
        b.m[1][i] = num[i];
        b.m[i][i - 1] = 1;
    }
    while(n)
    {
        if(n & 1)
            a = pow(b, a);
        n>>= 1;
        b = pow(b, b);
    }
    return a;
}

int main()
{
    while(~scanf("%lld%lld", &k, &m))
    {
        for(int i = 1; i <= 10; i++)
            scanf("%lld", &num[i]);
        if(k < 10)
            printf("%lld\n", k);
        else
        {
            Matrix ans;
            for(int i = 1; i <= 10; i++)
                ans.m[i][1] = 10 - i;
            ans = pow_matrix(ans, k - 9);
            printf("%lld\n", ans.m[1][1]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值