20-1-23-匈牙利算法-POJ3041

POJ3041

Asteroids

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 29541Accepted: 15802

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X.X..X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold

#pragma warning(disable:4996)
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

const int maxn = 505;//顶点的个数
const int maxm = 10005;

int n, m;
int g[maxn][maxn];
int linker[maxn];
bool used[maxn];


bool dfs(int u) {
	for (int v = 0; v < n; v++) {
		if (g[u][v] && !used[v]) {
			used[v] = true;
			if (linker[v] == -1 || dfs(linker[v])) {
				linker[v] = u;
				return true;
			}
		}
	}
	return false;
}


int hungary() {
	int res = 0;
	memset(linker, 0xff, sizeof(linker));
	for (int u = 0; u < n; u++) {
		memset(used, false, sizeof(used));
		if (dfs(u)) {
			res++;
		}
	}
	return res;
}

int main() {
	cin >> n >> m;
	int u, v;
	for (int i = 0; i < m; i++) {
		scanf("%d%d", &u, &v);
		g[u - 1][v - 1] = 1;
	}
	/*for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			cout << g[i][j] << " ";
		}
		cout << "\n";
	}*/
	cout << hungary() << "\n";
	return 0;
}


*对匈牙利算法有问题的话可以看这个博客详解匈牙利
运行以下程序以查看上述博客样例的运行结果

#pragma warning(disable:4996)
#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
/* ***********************************************************
//二分图匹配(匈牙利算法的DFS 实现)(邻接矩阵形式)
//初始化:g[][] 两边顶点的划分情况
	//建立g[i][j] 表示i->j 的有向边就可以了,是左边向右边的匹配
	//g 没有边相连则初始化为0
//uN 是匹配左边的顶点数,vN 是匹配右边的顶点数

//调用:res=hungary(); 输出最大匹配数
//优点:适用于稠密图,DFS 找增广路,实现简洁易于理解
//时间复杂度:O(VE)
//临接矩阵的最坏时间复杂度:O(n^3)
//*************************************************************/
//顶点编号从0 开始的

const int MAXN = 510;
int uN, vN;//u,v 的数目,使用前面必须赋值
int g[MAXN][MAXN] = { {1,1,0,0},{0,1,1,0},{1,1,0,0},{0,0,1,0} };//邻接矩阵
int linker[MAXN];//存储结果, 顶点i匹配得到的顶点j的编号
bool used[MAXN];//顶点V是否匹配过

bool dfs(int u) {
	for (int v = 0; v < vN; v++) {
		if (g[u][v] && !used[v]) {//匹配到第一个空闲的节点
			used[v] = true;
			if (linker[v] == -1 || dfs(linker[v])) {//被匹配的那个节点没有和其它人已匹配或者和该节点匹配的其他人能找到人匹配
				linker[v] = u;
				return true;
			}
		}
	}
	return false;
}

int hungary() {
	int res = 0;//成功匹配的最大个数
	memset(linker, -1, sizeof(linker));//存储结果
	for (int u = 0; u < uN; u++) {//给每一个顶点匹配
		memset(used, false, sizeof(used));
		if (dfs(u)) {//成功匹配
			res++;
		}
	}
	return res;
}


int main() {
	uN = 4;
	vN = 4;
	cout << hungary() << endl;
	for (int i = 0; i < 4; i++) {
		cout << i << " " << linker[i] << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值