nyoj163phone list 字典树

Phone List

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

输入
The first line of input gives a single integer, 1 ≤ t ≤ 10, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 100000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
输出
For each test case, output "YES" if the list is consistent, or "NO" otherwise.
样例输入
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
样例输出
NO

YES

此处附上讲解比较好的字典树的模版代码http://www.cnblogs.com/tanky_woo/archive/2010/09/24/1833717.html

 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX 11
typedef struct node
{
    int flag;//可记录字典树中某一串是否到结尾
    struct node *next[10];
}Lnode;
//初始化
Lnode *creat_list()
{
    Lnode *head;
    int i;
    head = (Lnode *)malloc(sizeof(Lnode));
    if(head == NULL)
    {
        printf("no memory available\n");
        exit(1);
    }
    for(i = 0; i < 10; i++)
    {
        head->next[i] = NULL;
    }
    head->flag = 0;
    return head;
}
//构建插入字典树
int insert_list(Lnode *root, char *s)
{
    int i, flag = 0;
    Lnode *phead = root;
    for(i = 0; s[i] != 0; i++)
    {
        if(phead->next[s[i] - '0'] == NULL)
        {
            phead->next[s[i] - '0'] = creat_list();
            flag = 1;
        }
        phead = phead->next[s[i] - '0'];
        if(phead->flag == 1)
            return 0;//说明该字符串还么有创建完就发现字典树以到末尾,说明此字典树中有该字符串的前缀,输出No
    }
    phead->flag = 1;//一个单词结尾标志赋值为1
    if(flag == 0)
        return 0;//说明没有重新构建结点,说明该字符串是此字典树中某一字符串的前缀,输出No
    return 1;//说明相互无前缀
}
//释放内存
void delete_list(Lnode *head)
{
    int i;
    if(head != NULL)
    {
        for(i = 0; i < 10; i++)
        {
            delete_list(head->next[i]);
        }
        free(head);
        head = NULL;
    }
}
int main()
{
    int n, num, flag;
    scanf("%d", &n);
    char s[MAX];
    Lnode *root;
    while(n--)
    {
        flag = 1;
        scanf("%d", &num);
        root = creat_list();
        while(num--)
        {
            getchar();
            scanf("%s", s);
            if(flag == 1)
                flag = insert_list(root, s);
        }
        delete_list(root);
        if(flag == 0)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}
        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值