nyoj1168An Easy Problem

An Easy Problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述
    In this problem, you are given two integers L and R, and your task is to calculate the sum of all the number's square between L and R(inclusive).
输入
The first line contains an integer T, indicates the number of test case.
The next T lines, each line contains two integers L and R(1≤L,R≤10^5).
输出
Print an integer represents the sum.
样例输入
2
1 2
2 4
样例输出
5

29

简单的题目超时的时候多想想有没有数学公式可以解题

#include<stdio.h>
int main()
{
	int test;
	scanf("%d",&test);
	while(test--)
	{
		long long a,b,sum;
		scanf("%lld%lld",&a,&b);
		if(a>b)
		{
			int temp= a;
			a=b;
			b=temp;
		}
		printf("%lld\n",b*(b+1)*(2*b+1)/6-a*(a+1)*(2*a+1)/6+a*a);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值