搜索初步-1005

Problem Description
Mr. West bought a new car! So he is travelling around the city.
One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.
Can Mr. West go across the corner?
 

Input
Every line has four real numbers, x, y, l and w.<br>Proceed to the end of file.

Output
If he can go across the corner, print "yes". Print "no" otherwise.<br>
 

Sample Input
  
  
10 6 13.5 4
10 6 14.5 4
 

Sample Output
  
  
yes
no
汽车拐弯问题,给定X, Y, l, d判断是否能够拐弯。首先当X或者Y小于d,那么一定不能。
其次我们发现随着角度θ的增大,最大高度h先增长后减小,即为凸性函数,可以用三分法来求解。

这里的Calc函数需要比较繁琐的推倒公式:
s = l * cos(θ) + w * sin(θ) - x;
h = s * tan(θ) + w * cos(θ);
其中s为汽车最右边的点离拐角的水平距离, h为里拐点最高的距离, θ范围从0到90。
3分搜索法
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#define eps 1e-8

struct point
{
    double x;
    double y;
};
double w1,w2,l,d;

double cross(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}

double cal(double x)
{
    point t1,t2,p0;
    double s,y,h;
    y=sqrt(l*l-x*x);
    t1.x=w1-x,t1.y=-w2;
    t2.x=w1,t2.y=-(w2-y);
    p0.x=0,p0.y=0;
    s=fabs(cross(t1,t2,p0));
    h=s/l;
    return h;
}

void solve()
{
    int i;
    double left,right,mid1,mid2,h1,h2;
    left=0,right=l;
    for(i=0;i<=100;i++)
    {
        mid1=(left*2+right)/3;
        mid2=(left+right*2)/3;
        h1=cal(mid1);
        h2=cal(mid2);
        if(h1>h2)
        {
            left=mid1;
        }
        else
        {
            right=mid2;
        }
    }
    double H=cal(left);
    if(H-d>0)
        printf("yes\n");
    else
        printf("no\n");
}

int main()
{
    while(scanf("%lf%lf%lf%lf",&w1,&w2,&l,&d)!=EOF)
    {
        if(d>=w1||d>=w2)
        {
            printf("no\n");
            continue;
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值