Turn the corner(HDU-2438)

Problem Description

    Mr. West bought a new car! So he is travelling around the city.

    One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

    Can Mr. West go across the corner?

 

Input

    Every line has four real numbers, x, y, l and w.

    Proceed to the end of file.

Output

     If he can go across the corner, print "yes". Print "no" otherwise.

Sample Input

    10 6 13.5 4

    10 6 14.5 4

Sample Output

    yes
    no

思路:

汽车已转弯,设水平方向为x轴,垂直方向为y轴。

则汽车的内边界的直线方程式f(x):y=x*tan(θ)+l*sin(θ)+d/cos(θ).其中θ是汽车与x轴的夹角。

尽可能让车贴着外面的墙璧转弯,也就是图中的x轴和y轴,此时红线的方程就是图中的方程,此时p点的位置就是让y=X时解得的x值,要保证p点在Y内,也就是-x<y,假若在转弯的所有角度中都满足这个条件,那么就能转弯,分析得,-x先增大后减小,所以用三分求最大-x值。

图示: 

(图源网络 侵权致歉)

Source Program

#include<cstdio>
#include<cmath>
#define PI acos(-1.0)
double x,y,l,w;

inline double calculate(double angle)//计算当前角度下允许通过的长度
{
    return -x*tan(angle)+l*sin(angle)+w/cos(angle);
}
int main()
{
    double right,left,mid,midmid;
   
    while( scanf("%lf%lf%lf%lf",&x,&y,&l,&w)!=EOF )//输入街道长、宽与汽车长、宽
    {
         /*三分查找最大角度*/
        left=0;right=PI/2;//设置上、下界初值,在0~90°寻找
        while(right-left>1e-10)
        {
            mid=(left+right)/2;//计算中值
            midmid=(mid+right)/2;//计算中值
            if(calculate(mid)<calculate(midmid))
            	left=mid;
            else
                right=midmid;
        }  
        if(calculate(mid)<=y)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值