hdu4791-Alice's Print Service(离线+暴力)

Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1570    Accepted Submission(s): 372


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 




题意: 打印东西,给出区间(张数)对应费用(到达一定张数就都按某更低的价格),m次询问,问最优费用。给的时候按张数递增给的。

思路:看见网上的大神用线段树或者dp做这道题,我表示无语。

像这种询问次数暴多、每次询问查找思路一样、数据还是有序的,简单暴力搜索就好啦!

把价格区间存好,并计算区间当前最小花费存入。存入所有询问数。将边数与询问数同时增加来进行符合比较,得出所求值。

再按原先记录的顺序输出!OK!收工!

分析一下复杂度。虽然是暴力搜索,但m次询问整体只搜索一遍,所以复杂度是o(n)


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
struct qq
{
    ll l,id;
    friend bool operator <(const qq &a,const qq &b)
    {
        return a.l<b.l;
    }
}q[100005];
ll anw[100005];
ll a[100005][3];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        for(int i=1;i<=n;i++){scanf("%lld %lld",&a[i][0],&a[i][1]);}
        ll minn=a[n][0]*a[n][1];
        for(int i=n-1;i>=1;i--){a[i][2]=minn;minn=min(minn,a[i][0]*a[i][1]);}
        for(int i=1;i<=m;i++){scanf("%d",&q[i].l),q[i].id=i;}
        sort(q+1,q+1+m);
        int i=1,j=1;
        a[n+1][0]=1000000005;
        a[n][2]=99999999999999999;
        while(i<=n)
        {
            for(;j<=m&&q[j].l<a[i+1][0];j++)
            {
                anw[q[j].id]=min(a[i][2],a[i][1]*q[j].l);
            }
            i++;
        }
        for(int k=1;k<=m;k++)
            printf("%lld\n",anw[k]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值