hdu 4791 Alice's Print Service (DP+离线处理)

Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1163    Accepted Submission(s): 270


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 


题意:给n种方案,打印量≥ si 时,每张纸的打印价格为pi(0≤n≤100000),问打印m次

询问,打印 qi 张时最少需要多少钱(0≤m≤100000)。


思路 : 先将询问都储存起来,然后按需求从小到大排序,依次求出答案,最后再输出。


#include <iostream>
#include <algorithm>
#include <cstdio>
#define ll long long
using namespace std;
const int maxn=100005;

struct node
{
    ll s,p,cost;
}a[maxn];
struct code
{
    int index;
    ll ans,num;
}b[maxn];
int n,m;

bool cmp1(code p,code q)
{
    return p.num<q.num;
}

bool cmp2(code p,code q)
{
    return p.index<q.index;
}

void input()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)  scanf("%I64d%I64d",&a[i].s,&a[i].p);
    for(int i=0;i<m;i++)
    {
         scanf("%I64d",&b[i].num);
         b[i].index=i+1;
    }
    sort(b,b+m,cmp1);
}

void solve()
{
    a[n-1].cost=a[n-1].s*a[n-1].p;
    for(int i=n-2;i>=0;i--)  a[i].cost=min(a[i].s*a[i].p,a[i+1].cost);

    int cnt=0;
    for(int i=0;i<m;i++)
    {
         while(cnt<n && a[cnt].s<=b[i].num)  cnt++;
         if(cnt==n)  b[i].ans=b[i].num*a[n-1].p;
         else  b[i].ans=min(b[i].num*a[cnt-1].p,a[cnt].cost);
    }
    sort(b,b+m,cmp2);
    for(int i=0;i<m;i++)   printf("%I64d\n",b[i].ans);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        input();
        solve();
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值