POJ 1861 Network【最小生成树kruskal,板子题】

题目链接

Network

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 18694 Accepted: 7540 Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
3
1 2
1 3
3 4

思路

首先说明一下,题目给的测试样例结果错了,我在上面改了一下;
板子题,输入网络,输入最小生成树中最大的边、边的总对数(必然是n-
1)、具体的边(从小到大输出)

kruskal代码
#include <iostream>
#include <algorithm>
#include <memory.h>
using namespace std;

struct edge{
    int from;
    int to;
    int value;
}a[15005];

int n,m;
int f[1005];
int mn;
int way[1005];

bool cmp(edge a,edge b){
    return a.value<b.value;
}

int getf(int x){//并查集一部分,查找老大
    if(f[x]==x){
        return x;
    }
    else{
        f[x]=getf(f[x]);
        return f[x];
    }
}

void mrge(int x,int y){//并查集一部分,合并,路径压缩
    int t1=getf(x);
    int t2=getf(y);
    if(t1<t2){//这样写是为了更严谨,虽然一般输入都是先小后大
        f[t2]=t1;
    }
    if(t2<t1){
        f[t1]=t2;
    }
}

void kruskal(){
    mn=0x3f3f3f3f;
    int k=0;
    for(int i=1;i<=n;i++)
        f[i]=i;
    sort(a+1,a+m+1,cmp);
    int sum=0;
    int cnt=0;
    for(int i=1;i<=m;i++){
        int t1=getf(a[i].from);
        int t2=getf(a[i].to);
        if(t1!=t2){
            mrge(t1,t2);
            way[++k]=i;//记录路径
            sum+=a[i].value;
            cnt++;
        }
        if(cnt==n-1){
            cout<<a[i].value<<endl;//最小中的最大
            cout<<n-1<<endl;//总对数
            for(int i=1;i<=n-1;i++){//输出路径
                int idx=way[i];
                cout<<a[idx].from<<" "<<a[idx].to<<endl;
            }
            return;//退出
        }
    }
}

int main()
{
    while(cin>>n>>m){
        for(int i=1;i<=m;i++){
            cin>>a[i].from>>a[i].to>>a[i].value;
        }
        kruskal();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值