HDU 3549 Flow Problem(Edmond Karp算法)

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 20158    Accepted Submission(s): 9484


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
 
 
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1
 

Sample Output
 
 
Case 1: 1Case 2: 2
 

Author
HyperHexagon
 

Source
 

Recommend
zhengfeng



【思路】

最大流模板题,运用Edmond Karp算法求解。


【代码】

//******************************************************************************
// File Name: HDU_3549.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年05月17日 星期四 22时52分17秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;

const int MAXN = 205, INF = 0x3f3f3f3f;

struct edge {
	int from, to, cap, flow;
	
	edge() {}
	edge(int u, int v, int c, int f) : from(u), to(v), cap(c), flow(f) {}
};

int t, n, m;
vector<edge> e;
vector<int> g[MAXN];
int p[MAXN], a[MAXN];
queue<int> q;

void init()
{
	e.clear();
	for (int i = 1; i<= n; i++) g[i].clear();
}

void add_edge(int from, int to, int cap, int flow)
{
	e.push_back(edge(from, to, cap, flow));
	g[from].push_back(e.size() - 1);
}

int edmond_karp(int s, int t)
{
	int ans = 0;
	while (true) {
		memset(a, 0, sizeof(a));
		a[s] = INF;
		while (!q.empty()) q.pop();
		q.push(s);
		while (!q.empty()) {
			int u = q.front(); q.pop();
			for (int i = 0; i < g[u].size(); i++) {
				edge &now = e[g[u][i]];
				if (!a[now.to] && now.cap - now.flow > 0) {
					p[now.to] = g[u][i];
					a[now.to] = min(a[u], now.cap - now.flow);
					q.push(now.to);
				}
			}
			if (a[t]) break;
		}
		if (!a[t]) break;
		for (int i = t; i != s; i = e[p[i]].from) {
			e[p[i]].flow += a[t];
			e[p[i] ^ 1].flow -= a[t];
		}
		ans += a[t];
	}
	return ans;
}

int main()
{
	scanf("%d", &t);
	for (int kase = 1; kase <= t; kase++) {
		scanf("%d %d", &n, &m);
		init();
		while (m--) {
			int u, v, c;
			scanf("%d %d %d", &u, &v, &c);
			add_edge(u, v, c, 0);
			add_edge(v, u, 0, 0);
		}
		int ans = edmond_karp(1, n);
		printf("Case %d: %d\n", kase, ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值