HDU 1695 GCD(莫比乌斯反演)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15050    Accepted Submission(s): 5762


 

Problem Description

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

 

 

Output

For each test case, print the number of choices. Use the format in the example.

 

 

Sample Input

2

1 3 1 5 1

1 11014 1 14409 9

 

Sample Output

 

Case 1: 9

Case 2: 736427

 

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

Source

 

2008 “Sunline Cup” National Invitational Contest

 

 

Recommend

wangye   |   We have carefully selected several similar problems for you:  1689 1690 1693 1691 1698 

 

【思路】

说实话,对于许多题目已经有许多人写过题解了,在此写字摆弄公式,我不过拾人牙慧耳,在需要数学功底的地方我甚至常有理解不足,但是出于整理自己思想之目的,我觉得还是有必要在此记录一下。关于莫比乌斯反演,这里是个开始。

第一类莫比乌斯反演:F(n) = \sum_{d | n}f(d) \Rightarrow f(n) = \sum_{d | n} \mu(\frac{n}{d}) F(d)

第二类莫比乌斯反演:F(n) = \sum_{n | d}f(d) \Rightarrow f(n) = \sum_{n | d}\mu(\frac{d}{n})F(d)

在此用到的是第二类莫比乌斯反演,我们设F(n)是gcd(x, y)是n的倍数的(x, y)点对的对数,f(n)是gcd(x, y)是n的(x, y)点对的对数,那么我们要求的就是f(k)。因为f(n)并不好求,而F(n)函数更好求一点,我们可以把F(n)算出来再反演得到f(n)。

假设x∈[1, B],y∈[1, D],则F(n) = floor(B / n) * floor(D / n),注意这里x、y数对有顺序。

对反演等式的右式,我们令i代表式子里的d是n的i倍(注意我说的是式子里的d)。

又令p = b / k,q = d / k,则f(k) = \sum_{i = 1}^{min(p, q)}\mu(i)\left \lfloor \frac{p}{i} \right \rfloor\left \lfloor \frac{q}{i} \right \rfloor,最后的这个就能求了!

另外,由于题目要求的x、y是无顺序的,还要去掉数重复的,详见代码。

 

【代码】

//******************************************************************************
// File Name: HDU_1695.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年08月04日 星期六 22时27分43秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long ll;

const int MAXN = 1e5 + 5;

int t, a, b, c, d, k;
vector<int> prime;
int mobius[MAXN];
bool done[MAXN];

void get_mobius(int n)
{
	memset(mobius, 0, sizeof(mobius));
	memset(done, false, sizeof(done));
	mobius[1] = 1;
	for (int i = 2; i < n; i++) {
		if (!done[i]) mobius[i] = -1, prime.push_back(i);
		for (int j = 0; j < prime.size() && (ll)i * prime[j] < n; j++) {
			done[i * prime[j]] = true;
			if (i % prime[j] == 0)
				break;
			else
				mobius[i * prime[j]] = -mobius[i];
		}
	}
}

ll solve(int p, int q)
{
	ll  ans = 0;
	for (int i = 1; i <= min(p, q); i++)
		ans += (ll)mobius[i] * (p / i) * (q / i);
	return ans;
}

int main()
{
	get_mobius(MAXN);
	scanf("%d", &t);
	for (int i = 1; i <= t; i++) {
		scanf("%d %d %d %d %d", &a, &b, &c, &d, &k);
		if (b > d) swap(b, d);
		printf("Case %d: ", i);
		if (k == 0) {
			printf("0\n");
			continue;
		}
		printf("%lld\n", solve(b / k, d / k) - solve(b / k, b / k) / 2);
	}
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值