HDU 1796 How many integers can you find(容斥原理)

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10614    Accepted Submission(s): 3159


 

Problem Description

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

 

 

Input

There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

 

 

Output

For each case, output the number.

 

 

Sample Input

12 2 2 3

 

 

Sample Output

7

 

 

Author

wangye

 

 

Source

2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

 

 

Recommend

wangye

 

【思路】

先去重,然后求不同数的组合(利用二进制思想)得到的最小公倍数,容斥一下即可,注意要求的是比N小的那些数的个数,所以N能整除的要去掉。

 

【代码】

//******************************************************************************
// File Name: HDU_1796.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年08月05日 星期日 10时21分43秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
typedef long long ll;

set<int> st;
int a[25];
int n, m;

ll gcd(ll a, ll b)
{
	return (!b ? a : gcd(b, a % b));
}

ll lcm(ll a, ll b)
{
	return a * b / gcd(a, b);
}

int main()
{
	while (scanf("%d %d", &n, &m) == 2) {
		int x;
		st.clear();
		for (int i = 1; i <= m; i++) scanf("%d", &x), st.insert(x);
		m = 0;
		for (set<int>::iterator it = st.begin(); it != st.end(); ++it)
			if (*it) a[++m] = *it;
		ll ans = 0, all = 1 << m;
		for (int i = 1; i < all; i++) {
			int cnt = 0, now = 1;
			for (int j = 0; j < m; j++)
				if (i & (1 << j)) cnt++, now = lcm(now, a[j + 1]);
			ans += (cnt & 1 ? 1 : -1) * (n / now);
			if (n % now == 0) ans -= (cnt & 1 ? 1 : -1);
		}
		printf("%lld\n", ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值