PAT甲级刷题(A+B for Polynomials)1002

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:1002

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include<stdio.h>

int main()
{
    float co1,co2,coe1[1005],coe2[1005];
    int k1,k2,ex1,ex2,i,n=0;
    for(i=0;i<1005;i++)
    {
        coe1[i]=0;
        coe2[i]=0;
    }
    scanf("%d",&k1);
    while(k1--)
    {
       scanf("%d %f",&ex1,&co1);
       if(co1!=0)
        	coe1[ex1]=co1;
    }
    scanf("%d",&k2);
    while(k2--)
    {
        scanf("%d %f",&ex2,&co2);
        if(co2!=0)
        	coe2[ex2]=co2;
    }
    for(i=0;i<=1004;i++)
    {
        coe1[i]=coe1[i]+coe2[i];
        if(coe1[i]!=0)
        	n++;
    }
    if(n==0)
    	printf("0\n");
    else
    	printf("%d",n);
    for(i=1004;i>=0;i--)
    {
        if(coe1[i]!=0)
            printf(" %d %.1f",i,coe1[i]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值