POJ 1450 Gridland(我的水题之路——找规律)

Gridland
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5400 Accepted: 2972

Description

Background 

For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the "easy" problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the "hard" ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point. 

Problem 

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North-South or East-West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 * 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 * 3-Gridland, the shortest tour has length 6. 
 
Figure 7: A traveling-salesman tour in 2 ? 3-Gridland.


Input

The first line contains the number of scenarios. 

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.

Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.

Sample Input

2
2 2
2 3

Sample Output

Scenario #1:
4.00

Scenario #2:
6.00

Source


题中给出两个数字n和m,将组成一个n*m个点的矩阵,矩阵相邻的两点之间有,东、南、西、北、东南、东北、西南、西北八个方向。那么我需要从某一点出发,遍历所有的点有且仅有一次,问最短的距离是多少?

一开始看到这题以为是图论的题目,但是看到题中的解释,就觉得这个是一道找规律的题目,所以在演草纸上试了几遍就发现了如下规律:
1)如果n和m都为奇数,则距离为n * m + 1.414 - 1;
2)否则,距离为n*m;

注意点:
1)每个结果最后有一个空行

代码(1AC):
#include <cstdio>
#include <cstdlib>

int main(void){
    int casenum, ii;
    int n, m;
    double result;

    scanf("%d", &casenum);
    for (ii = 1; ii <= casenum; ii++){
        scanf("%d%d", &n, &m);
        if (n % 2 == 1 && m % 2 == 1){
            result = n * m + 0.41;
        }
        else{
            result = n * m;
        }
        printf("Scenario #%d:\n", ii);
        printf("%.2f\n\n", result);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值