POJ 2864 Pascal Library(我的水题之路——都来了么)

Pascal Library
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3383 Accepted: 1647

Description

Pascal University, one of the oldest in the country, needs to renovate its Library Building, because after all these centuries the building started to show the effects of supporting the weight of the enormous amount of books it houses. 

To help in the renovation, the Alumni Association of the University decided to organize a series of fund-raising dinners, for which all alumni were invited. These events proved to be a huge success and several were organized during the past year. (One of the reasons for the success of this initiative seems to be the fact that students that went through the Pascal system of education have fond memories of that time and would love to see a renovated Pascal Library.) 

The organizers maintained a spreadsheet indicating which alumni participated in each dinner. Now they want your help to determine whether any alumnus or alumna took part in all of the dinners.

Input

The input contains several test cases. The first line of a test case contains two integers N and D indicating respectively the number of alumni and the number of dinners organized (1 <= N <= 100 and 1 <= D <= 500). Alumni are identified by integers from 1 to N. Each of the next D lines describes the attendees of a dinner, and contains N integers Xi indicating if the alumnus/alumna i attended that dinner (Xi = 1) or not (Xi = 0). The end of input is indicated by N = D = 0.

Output

For each test case in the input your program must produce one line of output, containing either the word `yes', in case there exists at least one alumnus/alumna that attended all dinners, or the word `no' otherwise.

Sample Input

3 3
1 1 1
0 1 1
1 1 1
7 2
1 0 1 0 1 0 1
0 1 0 1 0 1 0
0 0

Sample Output

yes
no

Hint

Alumna: a former female student of a particular school, college or university. 
Alumnus: a former male student of a particular school, college or university. 
Alumni: former students of either sex of a particular school, college or university.

Source


有n个校友,d个筹款晚宴,问是否有至少一个校友,每一场晚宴都来了。在出席列表中,如果来了,用1表示,没来用0表示。

二维数组横向存储出席状态,之后纵向搜索一遍。

注意点:
1)n>= 100, d >= 510, d为横坐标,n为纵坐标,注意不要颠倒了(1RE)

代码(1AC 1RE):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int arr[510][110];

int main(void){
    int n, d;
    int i, j;
    int flag;

    while(scanf("%d%d", &n, &d), n != 0 || d != 0){
        memset(arr, 0, sizeof(arr));
        for (i = 0; i < d; i++){
            for (j = 0; j < n; j++){
                scanf("%d", &arr[i][j]);
            }
        }
        for (j = 0; j < n; j++){
            flag = 0;
            for (i = 0; i < d; i++){
                if (arr[i][j] == 1){
                    flag++;
                }
            }
            if (flag == d){
                break;
            }
        }
        if (flag == d){
            printf("yes\n");
        }
        else{
            printf("no\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值