POJ 3086 Triangular Sums(我的水题之路——三角数累加)

Triangular Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5437 Accepted: 3845

Description

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

1 3 45
2 4 105
3 5 210
4 10 2145

Source


有一种三角形增长的队列T[i],其中增长间隔每次加1.如同上图的三角形一样,1、3、6、10、15、21、28、36、45、55....,现在从键盘读入一个数字n(n <= 300),求W[n] = SUM(k * T[k +1]),(k=1,2,...n)。

其实直接暴力求解应该也可以,不过习惯使用先打表后输出的解题方法了。因为整个题目的结果是不会因为输入的改变而改变的,所以在初始化就将表打好,然后,读入输出。

注意点:
1)输出格式。
2)计算结果最大值有10^9,可以直接使用int类型
3)T的计算至少要计算到301。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int T[310];
int W[310];

void init(){
    int i, j;

    memset(W, 0, sizeof(W));
    T[1] = 1;
    for (i = 2; i <= 304; i++){
        T[i] = T[i - 1] + i;
    }
    W[1] = T[2];
    for (i = 2; i<= 303; i++){
        W[i] = W[i - 1] + i * T[i + 1];
    }
}

int main(void){
    int ii, casenum;
    int n;

    init();
    scanf("%d", &casenum);
    for (ii = 1; ii <= casenum; ii++){
        scanf("%d", &n);
        printf("%d %d %d\n", ii, n, W[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值