Yogurt factory POJ - 2393 酸奶厂 贪心

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

Input

  • Line 1: Two space-separated integers, N and S.

  • Lines 2…N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

  • Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large
    for a 32-bit integer.

Sample Input

4 5

88 200

89 400

97 300

91 500

Sample Output

126900

Hint

OUTPUT DETAILS: In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

这道题目的意思是酸奶工厂可以生产酸奶,并且不会坏掉,每周酸奶工厂需要上交一定数目的酸奶订单,这些酸奶可以是这周生产的,也可以是仓库剩下的。每周生产酸奶的价钱是变化的。但是仓库储存一单位酸奶一周需要交一定量的钱。
所以需要做的就是计算在给定的这几周内,生产酸奶的最小成本是多少。

这道题目需要贪心来做,从第二周开始,酸奶的来源就不确定了,这个时候就需要遍历以前的周数,看看以前生产酸奶的成本加上储存到本周的价钱相比较,选择最小的成本进行累加,

代码如下;

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define ll long long
using namespace std;

int a[10010],b[10010];
int main()
{
	int n,m;
	ll sum=0,ans=0;
	scanf("%d %d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%d %d",&a[i],&b[i]);//a[i]是钱数,b[i]是个数 
		sum=a[i];
		for(int j=1;j<i;j++)
		{
			sum=min(sum,a[j]+m*(i-j)*1ll);//long long 型和int 不能比较 
		}
		ans+=sum*b[i];
	 } 
	 printf("%lld\n",ans);
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值