W3 - Knight Moves

问题描述

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
在这里插入图片描述

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Code

/*
 * @Description: Knight Moves
 * @version: 
 * @Author: 
 * @Date: 2021-04-14 08:32:28
 * @LastEditors: Please set LastEditors
 * @LastEditTime: 2021-04-14 16:52:34
 */
// self
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
struct point
{
    int x;
    int y;
    int step;
};
bool flag[300][300];
queue<struct point> q;
int dir[8][2] = {{-2, -1}, {-1, -2}, {-2, 1}, {1, -2}, {2, -1}, {-1, 2}, {1, 2}, {2, 1}};
void BFS(int l, struct point start, struct point end)
{
    while (!q.empty())
        q.pop();
    flag[start.x][start.y] = true;
    q.push(start);
    while (!q.empty())
    {
        int x = q.front().x, y = q.front().y, step = q.front().step;
        if (x == end.x && y == end.y)
        {
            cout << step << endl;
            break;
        }
        for (int i = 0; i < 8; i++)
        {
            int nextX = x + dir[i][0], nextY = y + dir[i][1], nextStep = step + 1;
            if (nextX < 0 || nextX >= l || nextY < 0 || nextY >= l)
                continue;
            if (flag[nextX][nextY])
                continue;
            flag[nextX][nextY] = true;
            struct point temp;
            temp.x = nextX;
            temp.y = nextY;
            temp.step = nextStep;
            q.push(temp);
        }
        q.pop();
    }
}
int main()
{
    int n;
    cin >> n;
    while (n--)
    {
        int l, startX, startY, endX, endY;
        cin >> l >> startX >> startY >> endX >> endY;
        for (int i = 0; i < l; i++)
        {
            for (int j = 0; j < l; j++)
                flag[i][j] = false;
        }
        struct point start, end;
        start.x = startX;
        start.y = startY;
        start.step = 0;
        end.x = endX;
        end.y = endY;
        end.step = 0;
        BFS(l, start, end);
    }
    // system("pause");
    return 0;
}
// 该题提交了三次,通过
// 搜索的两种思路:DFS与BFS,深度优先搜索找到的解不一定就最优解,则需要处理所有的情况。
// 空间复杂度与时间复杂度都很高。
// 考虑广度优先,我刚开始卡住的地方是,如何判断该步是第几步,这就关系到了数据组织形式的问题。
// 用一个结构体,记录当前的位置与步数。
// 还要注意记录当前位置是否已经被处理,若已经被处理则不再处理,防止陷入死循环导致TLE与MLE
// 这也是在我DFS与BFS实现过程中遇见的共有问题。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

jian圣楠

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值