knight moves经典广搜(bfs)

 

Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.



Sample Input

      
      
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6


 

Sample Output
      
      
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.

 


 
题意:这个骑士和象棋的马一样走日字,看看从一个点到另一个点最少走几步。
思路:用到了队列,将第一个点压进去,在删除之前 取这个点的值,然后将这个点的下一步的点全部压进队列。
在这里用到了一个计数的数组。

 
#if 1 
#include<bits/stdc++.h>
using namespace std;
int step[8][8];
int dir[8][2]={{1,2},{1,-2},{-1,2},{-1,-2},{2,1},{2,-1},{-2,1},{-2,-1}};
bool pd(int x,int y) 
{
 if(x>=0 && x<=7 && y>=0 && y<=7) 
 return 1;
 else return 0;
} 
int starx,stary,endx,endy;
int bfs()
{
  memset(step,0,sizeof(step)); 
  queue <int>q;
  int x,y,x1,y1;
  q.push(starx);
  q.push(stary);
  step[x][y]=0;
  
  while(!q.empty())
  {
  	 x=q.front();
  	 q.pop();
  	 y=q.front();
  	 q.pop();
  	 
  if(x==endx && y==endy)  //看看现在的位置是不是 
  return step[x][y];
  
  else
  {
    for(int i=0; i<=7; i++)
    {
    	x1=x+dir[i][0];
    	y1=y+dir[i][1];
    	if(pd(x1,y1)) 
    	{
    		q.push(x1);
    		q.push(y1);
    		step[x1][y1]=step[x][y]+1;
		}
    	
	}
  }	
}

}

int main()
{
	char a[3],b[3];
	while(cin>>a>>b)
	{
		starx=a[0]-'a';
		stary=a[1]-'1';
		endx=b[0]-'a';
		endy=b[1]-'1';
		int ans=bfs();
		cout<<"To get from "<<a<<" to "<<b<<" takes "<<ans<<" knight moves."<<endl;
	
	}
	
}
#endif 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值