HDOJ 1301 Jungle Roads 最小生成树 kruskal && prim

23 篇文章 0 订阅
16 篇文章 0 订阅

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5413    Accepted Submission(s): 3902


Problem Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
 

Sample Input
  
  
9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
 

Sample Output
  
  
216 30
注-此题为: HDOJ 1301 Jungle Roads

                 POJ  1251  Jungle Roads

                 ZOJ  1406  Jungle Roads

说明:求最小生成树(用 克鲁斯卡尔)

题目大意:
        在相通n个岛屿的所有桥都坏了,要重修,
重修每一个桥所用的时间不同,求重修使每个岛屿都间接或直接与其他岛屿相同时所用的的最短时间(只有修完一个桥后才可修下一个桥)。------------求最小生成树。


数据:     数据输入的第一行n代表岛屿的个数,当为0是结束程序,接着n-1行开始时为这岛屿的编号,用大写字母表示,接着是一个整数 m,表示与该岛屿连接的字典序大于该岛屿编号的个数,然后该行输入 m 对数据,每对数据的第一个字母表示与该岛屿连通的岛屿的编号,第二个数字表示要重修两岛屿之间桥所需要的时间

在  POJ  提交时要将scanf 换成  cin ;printf   换成    cout  ;否则  RE 。

已AC代码:(kruscal)

#include<cstdio>
#include<algorithm>
using namespace std;

int n,m,per[125];     // 并查集 

struct node{
    int u,v,w;
}s[10010];

bool cmp(node a,node b)
{
    return a.w<b.w;
}

void itoa()      //初始化 
{
    for(int i=0;i<=30;++i)
        per[i]=i;
}

int find(int x)     // 查找根节点 
{
    return x==per[x]?x:per[x]=find(per[x]);
}

bool join(int a,int b)    //合并根节点,并判断是否成环 
{
    int fa=find(a);
    int fb=find(b);
    if(fa!=fb)
    {
        per[fa]=fb;
        return true;
    }
    return false;
}

int main()
{
    int i,j;
    while(scanf("%d",&n),n)
    {
        m=n-1;
        int p,q,a,b,k=0;
        char ch,str;
        while(m--)
        {
            getchar();
            scanf("%c%d",&ch,&p);
            for(i=0,j=0;i<p;++i,++j)
            {
                a=ch-'A';
                s[k].u=a;
                getchar();
                scanf("%c%d",&str,&q);
                b=str-'A';
                s[k].v=b;
                s[k].w=q;
                k++;
            }
        }
        sort(s,s+k,cmp);    //按  w  从小到大排序 
        itoa();      //初始化根节点 
        int sum=0; 
        for(i=0;i<k;++i)
        {
            if(join(s[i].u,s[i].v))
            {
                sum+=s[i].w;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


prim  首先要初始化,为无穷大,这样,不符合条件的,和就不会被取到

已AC代码:(prim

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0xfffffff
using namespace std;

int map[125][125],low[125];
int vis[125];   //map二维数组存图,low记录每2个点间最小权值,vis标记某点是否已访问
int n,m,sum;

void prim()
{
	int min;
	int i,j,pos=0;
	memset(vis,0,sizeof(vis));
	
	for(i=1;i<=n;++i)   	//从某点开始,分别标记vis和记录该点pos
		low[i]=map[1][i];  //第一次给low数组赋值 map的第一行 
	vis[1]=1;
	
	for(i=1;i<n;++i)   //再运行n-1次,一次找一个最小 
	{
		min=INF;
		for(j=1;j<=n;++j)
		{
			if(vis[j]==0&&low[j]<min)
			{
				min=low[j];
				pos=j;
			}
		}
		
		vis[pos]=1;    //标记该点已访问 
		sum+=min;   //最小权值累加
		
		for(j=1;j<=n;++j)     //更新权值low 把 map的 pos 行中比对应的 low 小的赋给low 
			if(vis[j]==0&&low[j]>map[pos][j])
				low[j]=map[pos][j];
	}
	return ;
}

int main()
{
	int i,j;
	while(cin>>n,n)
	{
		for(i=1;i<=n;++i)  //初始化,无穷大 
		{
			for(j=1;j<=n;++j)
				map[i][j]=INF;
		}
		m=n-1;
		int p,q,a,b,k=0;
		char ch,str;
		while(m--)
		{
			cin>>ch>>p;
			for(i=0,j=0;i<p;++i,++j)
			{
				a=ch-'A'+1;
				cin>>str>>q;
				b=str-'A'+1;
				map[a][b]=map[b][a]=q;     //建图 
			}
		}
		
		sum=0;
		prim();
		cout<<sum<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值