hdoj1301 Jungle Roads

题目:

Problem Description
http://acm.hdu.edu.cn/data/images/1301-1.gif
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30

题目很长,但基本意思就是求最小生成树,图片也是演示求最小生成树。

求最小生成树有两种方法:Prim 和 Kruskal. 我用的是后者。

参考代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
const int MAXV = 30+10;
const int MAXE = 200+10;
using namespace std;
int par[MAXV];
struct node {
    int u,v,cost;
} e[MAXE];
bool operator < (const node &a,const node &b) {
    return a.cost < b.cost;
}
int n;
void init() {
    for (int i = 0;i < n;++i) {
        par[i] = i;
    }
    memset(e,0,sizeof(e));
}
int find(int x) {
    if (x == par[x]) return x;
    else return par[x] = find(par[x]);
}
int main() {
    while (scanf("%d", &n) != EOF && n) {
        init();
        char letter;
        int roads;
        int j = 0;
        for (int i = 0;i < n-1;++i) {
            getchar();
            //cout << "xyz" << endl;
            scanf("%c%d", &letter, &roads);
            for (int k = 0;k < roads;++k) {
                e[j].u = letter - 'A';
                char letter2;
                int costs;
                getchar();
                //cout << "xyz" << endl;
                scanf("%c%d", &letter2, &costs);
                e[j].v = letter2 - 'A';
                e[j].cost = costs;
                j++;
            }
        }
        int count = 0;
        sort(e,e+j);
        for (int i = 0;i < j;++i) {
            int x = find(e[i].u);
            int y = find(e[i].v);
            if (x != y) {
                par[y] = x;
                count += e[i].cost;
            }
        }
        printf("%d\n", count);
    }
    return 0;
}

说明一下这道题的输入:
第一行是一个数字,代表n个村庄。
接下来的n-1行:
第一个是起点,之后是它可以到多少个村庄,然后就是它到的村庄和权值。
此题输入字符时要小心(吞字符现象)。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值