HDOJ 4324 Triangle LOVE(拓扑排序)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3614    Accepted Submission(s): 1423


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
注 - 此题为:  HDOJ 4324 Triangle LOVE(拓扑排序)

说明: 题意 用   拓扑排序    如果是判断三角恋或多角恋关系也就是 判断是否成环 , 成环就输出 No,否则,输出Yes

已AC代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
int map[2010][2010];
int indegree[2010];
char str[2010];
int n;

void Topo()
{
	int i,j,top,k=0;
	queue<int>Q;
	for(i=0;i<n;++i)
	{
		if(indegree[i]==0)
		{
			Q.push(i);
		}
	}
	while(!Q.empty())
	{
		int top=Q.front();
			Q.pop();
		indegree[top]=-1;
		k++; //记录个数 
		for(i=0;i<n;++i)
		{
			if(map[top][i])indegree[i]--;
			if(indegree[i]==0)Q.push(i);
		}
	}
	if(k==n)  //成环输出 No 
		printf("No\n"); 
	else
		printf("Yes\n");  //不成环输出 
}
int main()
{
	int T,i,j,cas=1;
	char ch[2100];
	scanf("%d",&T);
	while(T--)
	{
		memset(indegree,0,sizeof(indegree));
		memset(map,0,sizeof(map));
		scanf("%d",&n);
		for(i=0;i<n;++i)
		{
			scanf("%s",ch);  //需要用 %s 读入,否则可能超时 
			for(j=0;j<n;++j)
			{
				map[i][j]=ch[j]-'0';
				if(map[i][j+1]==1)
					indegree[j+1]++;
			}
		}
		printf("Case #%d: ",cas++);
		Topo();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值