HDOJ 4324 Triangle LOVE(拓扑排序判断有向图是否存在环)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3981    Accepted Submission(s): 1572


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No


题意:给出一个n*n的矩阵,a[i][j]为1表示第i个人喜欢第j个人,为0表示不喜欢。 判断这里面是否存在三角恋关系。

解题思路:按题意模拟建立图,很容易看出来这是个有向图。判断是否存在三角恋就是判断有向图是否存在环,用拓扑排序即可。

代码如下:

#include<cstdio>
#include<cstring>
int map[2010][2010];
int n,indegree[2010];
char str[2010];

void tuopu()
{
	int i,j,top,k=0;
	for(j=0;j<n;++j)
	{
		for(i=0;i<n;++i)
		{
			top=-1;
			if(indegree[i]==0)
			{
		        top=i;
				break;
			}
		}
		if(top==-1)
		{
			k=1;
			break;
			
		}
		else
		{
			indegree[top]=-1;
			for(i=0;i<n;++i)
		    {
			    if(map[top][i])
			       indegree[i]--;
		    }
		}
	}
	if(!k)
	   printf("No\n");
	else
	   printf("Yes\n");
} 

int main()
{
	int t,i,j,cnt=1;
	scanf("%d",&t);
	while(t--)
	{
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		scanf("%d",&n);
		for(i=0;i<n;++i)
		{
			scanf("%s",str);
			for(j=0;j<n;++j)
			{
				map[i][j]=str[j]-'0';
				if(map[i][j])
				   indegree[j]++;
			}
		}
		printf("Case #%d: ",cnt++);
		tuopu();
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值