02-线性结构3 Reversing Linked List (25分)

02-线性结构3 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^​5​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#include<iostream>
using namespace std;
typedef struct Node* PtrToNode;
struct Node {
	int add,key,nextadd;
	PtrToNode Next;
};

void Attach(int a,int b,int c,PtrToNode* List) {

	PtrToNode tmp=(PtrToNode)malloc(sizeof(Node));
	tmp->Next=NULL;
	tmp->add=a;
	tmp->key=b;
	tmp->nextadd=c;
	(*List)->Next=tmp;
	(*List)=tmp;
}
int main() {
	int first,N,K,value[100001],next[100001],count=0;
	int a,b,c;
	cin>>first>>N>>K;
	for(int i=0; i<N; i++) {
		cin>>a>>b>>c;
		value[a]=b;
		next[a]=c;
	}
	PtrToNode L=(PtrToNode)malloc(sizeof(Node)),Rear,tmp;
	Rear=L;
	L->Next=NULL;
	while(first!=-1) {
		count++;
		Attach(first,value[first],next[first],&Rear);
		first=next[first];
	}
	
	PtrToNode Old,New,T;
	Old=L->Next;
	New=NULL;
	T=L->Next;
	Rear=L;
	for(int i=1; i<=count/K; i++) {
		for(int j=1;j<=K;j++){
			tmp=Old->Next;
			Old->Next=New;
			if(New==NULL)Old->nextadd=-1;
			else Old->nextadd=New->add;
			New=Old;
			Old=tmp;
		}
		Rear->Next=New;
		Rear->nextadd=New->add;
		Rear=T;
		T=tmp;
		New=NULL;
	}
	if(T){
		Rear->Next=T;
		Rear->nextadd=T->add;
	}else{
		Rear->nextadd=-1;
		Rear->Next=NULL;
	}
	tmp=L;
	L=L->Next;
	free(tmp);
	Rear=L;
	
	int i=0;
	
	Rear=L; 
	while(Rear){
		i++;
		if(i!=count)printf("%05d %d %05d\n",Rear->add,Rear->key,Rear->nextadd);
		else printf("%05d %d %d\n",Rear->add,Rear->key,-1);
		Rear=Rear->Next;
	}
	
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值