堆栈应用之简单计算器

简单计算器

题目描述:

读入一个只包含+,-,*,/的非负整数计算表表达式,计算该表达式的值

输入格式:

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应结果不要输出。

输出格式:

对每个从测试用例输出一行,即该表达式的值,精确到小数点后2位。

样例输入:

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出;

12178.21

#include<bits/stdc++.h>
using namespace std;
struct node{
	double num; //操作数 
	char op;//操作符
	bool flag; //true表示操作数,false表示操作符 
}; 

string str;
stack<node>s;//操作符栈
queue<node>q;//后缀表达式序列 
map<char,int>op;

void Change(){	//将中缀表达式转化为后缀表达式 
	double num;
	node temp;
	for(int i=0;i<str.size();){
		if(isdigit(str[i])){
			temp.flag=true;
			temp.num=str[i++]-'0';
			while(i<str.size()&&isdigit(str[i])){
				temp.num=temp.num*10+str[i]-'0';//更新这个操作数 
				i++; 
			}
			q.push(temp); //将这个操作数压入后缀表达式 
		}else{
			temp.flag=false;//标记是操作符
			//只要操作符栈的栈顶元素比该操作符优先级高 
			//就把操作符栈的栈顶元素弹出到后缀表达式的队列中 
			while(!s.empty()&&op[str[i]]<=op[s.top().op]){
				q.push(s.top());
				s.pop();
			} 
			temp.op=str[i];
			s.push(temp);//把该操作符压入操作符栈中
			i++; 
		}
		
	}
	//如果操作符栈中还有操作符,就把它弹出到后缀表达式队列中
		while(!s.empty()) {
			q.push(s.top());
			s.pop();
		} 
}
double Cal(){ //计算后缀表达式 
	double temp1,temp2;
	node cur,temp;
	while(!q.empty()){
		cur=q.front();
		q.pop();
		if(cur.flag==true)s.push(cur);
		else{
			temp2=s.top().num;
			s.pop();
			temp1=s.top().num;
			s.pop();
			temp.flag=true;
			if(cur.op=='+')temp.num=temp1+temp2;
			else if(cur.op=='-')temp.num=temp1-temp2;
			else if(cur.op=='*')temp.num=temp1*temp2;
			else temp.num=temp1/temp2;
			s.push(temp);
		}
	} 
	return s.top().num;
}
int main(){
	op['+']=op['-']=1;
	op['*']=op['/']=2;
	while(getline(cin,str),str!="0"){
		for(string::iterator it=str.end();it!=str.begin();it--){
			if(*it==' ')str.erase(it);
		}
		while(!s.empty())s.pop();
		Change();
		printf("%.2f\n",Cal());
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值