1034 Head of a Gang (30分)

43 篇文章 0 订阅

1034 Head of a Gang (30分)

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time
where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

ansDis是一个组织中通话总数的两倍,是每一个成员所通话的总数和,不用G[v][u]计算是防止环形图,用G[v][u]的话可以通过把G[v][u],G[u][v]重置为0来计算,这就用不到vis[]了只看两个顶点之间有没有边,又边的话在计算边长后把边长重置为0

#include<bits/stdc++.h>
using namespace std;
#define MaxV 3000
#define INF 1000000000
//d[]用于存储一个人的总通话时间,totalNum记录不同姓名人的总个数
int n,k,G[MaxV][MaxV],d[MaxV]={0},totalNum=0; 
bool vis[MaxV] = {false};
//StringToInt用来记录姓名和序号的映射,result用来存储最后的head名和人数
map<string,int>StringToInt,result;
//IntToString用来记录序号和人民的映射
map<int,string>IntToString;
//Judge用来判断这个名字是否是第一次出现
map<string,bool>Judge;

int getV(string name){
	if (!Judge[name]) {
		Judge[name] = true;
		StringToInt[name] = totalNum;
		IntToString[totalNum] = name;
		totalNum++;
	}
	return StringToInt[name];
}
void DFS(int S, int& index, int& ansSum, int& head){
	vis[S] = true;
	for (int i = 0; i < totalNum; i++){
		if (!vis[i]&&G[S][i] != 0) {
			if (d[i] > d[head]) {
				head = i;
			}
			index++;
			ansSum += d[i]; 
			DFS(i, index, ansSum, head);
		}
	}
}
int main(){
	scanf("%d%d",&k, &n);
	string name1, name2;
	int w, v, u, num = 0;
	fill(G[0], G[0] + MaxV * MaxV, 0);
	for (int i = 0; i < k; i++) {
		cin >> name1 >> name2 >> w;
		u = getV(name1);
		v = getV(name2);
		d[u] += w;
		d[v] += w;
		G[u][v] += w;
		G[v][u] += w;
	}
	for (int i = 0; i < totalNum; i++) {
		if (!vis[i]) {
			int index = 1, ansSum = d[i], p = i;
			DFS(i,index, ansSum, p);
			if (index > 2 && ansSum / 2 > n) {
				num++;
				result[IntToString[p]] = index;
			}
		}
	}
	printf("%d\n", num);
	for (auto i : result) {
		cout<< i.first << " " << i.second << endl; 
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值