1083 List Grades (25 分)

1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

#include<bits/stdc++.h>
using namespace std;
struct node{
	string name, id;
	int grade;
};
int N, s, e, flag = 0;
vector<node> v;
bool cmp(node a, node b) {
	return a.grade > b.grade;
}
int main() {
	scanf("%d", &N);
	v.resize(N);
	for (int i = 0; i < N; i++) {
		cin >> v[i].name >> v[i].id >> v[i].grade;
	}
	cin >> s >> e;
	sort(v.begin(), v.end(), cmp); 
	for (int i = 0; i < N; i++) {
		if (v[i].grade <= e && v[i].grade >= s) {
			flag = 1;
			cout << v[i].name << " " << v[i].id << endl;
		}
	}
	if (!flag) cout << "NONE";
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值