2020PAT甲级秋季7-1 Panda and PP Milk

7-1

Panda and PP Milk
在这里插入图片描述
PP milk (盆盆奶)is Pandas’ favorite. They would line up to enjoy it as show in the picture. On the other hand, they could drink in peace only if they believe that the amount of PP milk is fairly distributed, that is, fatter panda can have more milk, and the ones with equal weight may have the same amount. Since they are lined up, each panda can only compare with its neighbor(s), and if it thinks this is unfair, the panda would fight with its neighbor.

Given that the minimum amount of milk a panda must drink is 200 ml. It is only when another bowl of milk is at least 100 ml more than its own that a panda can sense the difference.

Now given the weights of a line of pandas, your job is to help the breeder(饲养员)to decide the minimum total amount of milk that he/she must prepare, provided that the pandas are lined up in the given order.

Input Specification:

Each input file contains one test case. For each case, first a positive integer n (≤10​4​​ ) is given as the number of pandas. Then in the next line, n positive integers are given as the weights (in kg) of the pandas, each no more than 200. the numbers are separated by spaces.

Output Specification:

For each test case, print in a line the minimum total amount of milk that the breeder must prepare, to make sure that all the pandas can drink in peace.

Sample Input:

10
180 160 100 150 145 142 138 138 138 140

Sample Output:

3000

Hint:

The distribution of milk is the following:

400 300 200 500 400 300 200 200 200 300

#include<bits/stdc++.h>
using namespace std;
int N;
vector<int> w, lefts;
int main() {
	scanf("%d", &N);
	w.resize(N);
	lefts.resize(N);
	for (int i = 0; i < N; i++) {
		lefts[i]  = 200;
		scanf("%d", &w[i]);
	}
	for (int i = N - 2; i >= 0; i--) {
		if (w[i] > w[i + 1] && lefts[i] <= lefts[i + 1]) {
			lefts[i] = lefts[i + 1] + 100;
		} else if (w[i] < w[i + 1] && lefts[i + 1] <= lefts[i]) {
			lefts[i + 1] = lefts[i] + 100;
		} else if (w[i] == w[i + 1]) {
			int maxs = max(lefts[i], lefts[i + 1]);
			lefts[i] = maxs;
			lefts[i + 1] = maxs;
		}
	}
	for (int i = 1; i <= N - 1; i++) {
		if (w[i] > w[i - 1] && lefts[i] <= lefts[i - 1]) {
			lefts[i] = lefts[i - 1] + 100;
		} else if (w[i] < w[i - 1] && lefts[i] >= lefts[i - 1]) {
			lefts[i - 1] = lefts[i] + 100;
		} else if (w[i] == w[i - 1]) {
			if (lefts[i] != lefts[i - 1]) {
				int maxs = max(lefts[i], lefts[i - 1]);
				lefts[i] = maxs;
				lefts[i - 1] = maxs;
			}
		}
	}
	int sum = 0;
	for (int i = 0; i < N; i++) {
		sum += lefts[i] ;
	}
	cout << sum;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值