7-3 File Path

作者 陈越

单位 浙江大学

The figure shows the tree view of directories in Windows File Explorer. When a file is selected, there is a file path shown in the above navigation bar. Now given a tree view of directories, your job is to print the file path for any selected file.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤103), which is the total number of directories and files. Then N lines follow, each gives the unique 4-digit ID of a file or a directory, starting from the unique root ID 0000. The format is that the files of depth d will have their IDs indented by d spaces. It is guaranteed that there is no conflict in this tree structure.

Then a positive integer K (≤100) is given, followed by K queries of IDs.

Output Specification:

For each queried ID, print in a line the corresponding path from the root to the file in the format: 0000->ID1->ID2->...->ID. If the ID is not in the tree, print Error: ID is not found. instead.

Sample Input:

14
0000
 1234
  2234
   3234
    4234
    4235
    2333
   5234
   6234
    7234
     9999
  0001
   8234
 0002
4 9999 8234 0002 6666

Sample Output:

0000->1234->2234->6234->7234->9999
0000->1234->0001->8234
0000->0002
Error: 6666 is not found.
#include<iostream>
#include<vector>
#include<unordered_map>
using namespace std;
const int N = 1010;
unordered_map<string,string> p;
int idx;
int n;
vector<string> v[N];
int flag = 1;
void print(string id){
    if(id=="")return;
    print(p[id]);
    if(flag)flag = 0;
    else printf("->");
    printf("%s",id.c_str());
}
int main(){
    scanf("%d",&n);
    getchar();
    for(int i = 0;i<n;i++){
        string id;getline(cin,id);
        int len = id.size();
        int d = len-4;
        string sid = id.substr(d);
        v[d].push_back(sid);
        if(d) p[sid] = v[d-1][v[d-1].size()-1];
    }
    int k;cin>>k;
    while(k--){
        string id;cin>>id;
        if(id!="0000"&&!p.count(id)) printf("Error: %s is not found.\n",id.c_str());
        else{
            flag = 1;
            print(id);
            puts("");
        }
    }
}

 

 

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值