PAT甲级7-3 1126 Eulerian Path (25分)

算法笔记总目录
关键英语单词解释

1126 Eulerian Path (25分)
In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题意:判定欧拉回路
思路 1.先判断是否是连通图(5分测试点)
2.顶点度数全部为偶为欧拉回路
两个顶点度数为奇为半欧拉回路
其他 不是欧拉回路
注:一个点的度数指:多少个点与这个顶点连接;

#include<bits/stdc++.h>
using namespace std;
int n,k,v1,v2,oddn=0,c=0;
unordered_map <int,int> mp;
const int maxn = 510;
bool visit[maxn];
vector< vector<int> > vi;
void dfs(int root){
    visit[root]=true;
    c++;
    for(int j=0;j<vi[root].size();j++){
        if(visit[vi[root][j]]==false) dfs(vi[root][j]);
    }
}
int main(){
	cin>>n>>k;
	vi.resize(n+1);
	for(int i=0;i<k;i++){
		cin>>v1>>v2;
		vi[v1].push_back(v2);
		vi[v2].push_back(v1);
	}
	for(int i=1;i<=n;i++){
		if(i<n)printf("%d ",vi[i].size());
		else 	printf("%d\n",vi[n].size());
		if(vi[i].size()%2!=0)oddn++;
	}
	dfs(1);
	if(c<n) printf("Non-Eulerian");
	else if(oddn == 2) printf("Semi-Eulerian");
	else if(oddn == 0) printf("Eulerian");
	else printf("Non-Eulerian");
	return 0;
}

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

隔壁de小刘

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值