PAT(甲级)2019年秋季考试7-1 Forever (20 分)

7-1 Forever (20 分)

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

the sum of all the digits of A is m;
the sum of all the digits of A+1 is n; and
the greatest common divisor of m and n is a prime number which is greater than 2.
Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

考察的点有点多,而且比较注意细节,排序, 求最大公约数, 质数的判断,各个数位的加法,还有一个是合理剪枝(不能直接遍历不然最后一个测试用例会超时),剪枝的话我是每次加100判断这个数数位之和和M的关系,如果大于M则继续遍历,如果小于M - 18(个位,十位最大和)则继续遍历,如果刚刚好在18之内,则去遍历这100个数(即j + 0 ~ 99)这样就不用遍历每一个数了。

#include<bits/stdc++.h>
using namespace std;
int K, L, m;
struct Node {
	int n, num;
	friend bool operator < (Node a, Node b) {
		if (a.n != b.n) return a.n < b.n;
		else return a.num < b.num;
	}
};
//求取数位和
int judge1(int num) {
	int temp = 0;
	while (num != 0) {
		temp += num % 10;
		num /= 10;
	}
	return temp;
}
//求取最大公约数
int judge2(int n, int m) {
	if (m != 0) return judge2(m, n % m);
	else return n;
}
//判断最大公约数是否是质数(2除外)
bool isPrime(int n) {
	if (n <= 2) return false;
	int sqr = sqrt(1.0 * n);
	for (int i = 2; i <= sqr; i++) {
		if (n % i == 0) return false;
	}
	return true;
}
int main() {
	scanf("%d", &K);
	for (int i = 0; i < K; i++) {
		scanf("%d %d", &L, &m);
		printf("Case %d\n", i + 1);
		int num = 1, flag = 0;
		vector<Node> ans;
		for (int j = 1; j < L; j++) num *= 10;
		for (int j = num; j < num * 10; j += 100) {
			if (judge1(j) > m) continue;
			else if (judge1(j)  + 18 < m) {
				continue;
			} else {
				for (int p = 0; p <= 99; p++) {
					if (judge1(j + p) == m) {
						int n = judge1(j + 1 + p);
						int div = judge2(n, m);
						if (isPrime(div)) {
							ans.push_back({n, j + p});
						}
						break;
					}
				}
			}
		}
		sort(ans.begin(), ans.end());
		if (ans.size() == 0) printf("No Solution\n");
		else {
			for (int j = 0; j < ans.size(); j++) {
				printf("%d %d\n", ans[j].n, ans[j].num);
			}
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
YOLO高设计资源源码,详情请查看资源内容中使用说明 YOLO高设计资源源码,详情请查看资源内容中使用说明 YOLO高设计资源源码,详情请查看资源内容中使用说明 YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明YOLO高设计资源源码,详情请查看资源内容中使用说明

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值