poj 1733 parity game

最近总是诡异的登不上hdu……所以从别处找了道并查集的题来做做……什么情况……

Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3840 Accepted: 1489

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

依旧是看了题完全茫然……这和并查集有一毛钱关系咩???然后看了题解参悟了……这也可以!map的用法和virtual friend 差不多,据说是用来离散化的(什么东西)?可能是因为数字的范围太大(1000000000) 而相对输入的question很少(5000)吧?奇偶判断让我想到了那道同性恋的题……虽然find和merge时的even数组的更新还是有些迷糊,不过已经能写出来了,只不过要自己想到还是有些难,而且不是很有把握……总之在进步吧~

一开始忘了把输入的第一个数减一……纠结好久……什么嘛……T^T

#include <iostream>
#include <string>
#include <map>
using namespace std;
int k;
int root[10002];
int even[10002];//there are odd or even 1 from i to the root 

map<int,int> p;
void init()
{
     
     k=1;
     int i;
     for(i=0;i<10002;i++)
     {
      //   even[i]=0;
         root[i]=-1;
     }
}

int find(int x)
{
    if(root[x]==-1)
    return x;
    
    int t=root[x];
    root[x]=find(root[x]);
    even[x]=(even[x]+even[t])%2;
    return root[x];
    
}
    
    
    
    
bool merge(int a,int b,int odd)
{
     int fa=find(a);
     int fb=find(b);
     if(fa==fb)
     {
         if((even[a]+even[b])%2==odd)
         return true;
         else
         return false;
     }
     else
     {
         root[fa]=fb;
         even[fa]=(even[a]+even[b]+odd)%2;
         return true;
     }
     
}
     
               
     

int main()
{
    int num;
    int n;
    cin>>num;
    cin>>n;
    init();
    int i;
    for(i=0;i<n;i++)
    {
         int a,b;
         string s;
         cin>>a>>b>>s;
         a--;//...........hey!
         if(p.find(a)==p.end())
         {
             p[a]=k++;
         }
         if(p.find(b)==p.end())
         {
             p[b]=k++;
         }
         int odd;
         if(s=="odd")
         odd=1;
         else
         odd=0;
         if(!merge(p[a],p[b],odd))
             break;
    }
    cout<<i<<endl;
    system("pause");
}
         




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值