hdu 5.2.8 2527 safe or unsafe

ただいま~~

为了在usaco上写下的宏愿。。开始继续刷hdu了。。。(喂!)

Safe Or Unsafe

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 45 Accepted Submission(s): 20
 
Problem Description
Javac++ 一天在看计算机的书籍的时候,看到了一个有趣的东西!每一串字符都可以被编码成一些数字来储存信息,但是不同的编码方式得到的储存空间是不一样的!并且当储存空间大于一定的值的时候是不安全的!所以Javac++ 就想是否有一种方式是可以得到字符编码最小的空间值!显然这是可以的,因为书上有这一块内容--哈夫曼编码(Huffman Coding);一个字母的权值等于该字母在字符串中出现的频率。所以Javac++ 想让你帮忙,给你安全数值和一串字符串,并让你判断这个字符串是否是安全的?
 
Input
输入有多组case,首先是一个数字n表示有n组数据,然后每一组数据是有一个数值m(integer),和一串字符串没有空格只有包含小写字母组成!
 
Output
如果字符串的编码值小于等于给定的值则输出yes,否则输出no。
 
Sample Input
2
12
helloworld
66
ithinkyoucandoit
 
Sample Output
no
yes
 

朴素的哈夫曼树……朴素也要知道这树到底是什么啊!好吧其实很早就知道它了,上次比赛也遇到了(虽然完全没看出来),但是这是第一次实现。

hdu的网抽了……明天再贴码吧。

好困……答应了某只要早睡的……

oj修复了~打开step的时候发现多了一个钩钩超满足啊~^-^~~

//safe or unsafe 
//hdu 2527
//huffman tree!
//point: when there is only one number, need a particular way
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

struct//each node of the tree
{
      int weight;
      int parent;//the number of parent
      int left;//the number of left child
      int right;
}node[60];

int main()
{
    int hash[30];//how many time did the character appear in string
    int i,j,k;//for loop...as usual
    char ch[10000];
    int cas;
    cin>>cas;
    while(cas--)
    {
        memset(hash,0,sizeof(hash));
        int lim;//use the number of tree compare with lim
        cin>>lim>>ch;
        int len=strlen(ch);
        for(i=0;i<len;i++)
            hash[ch[i]-96]++;//count the time each character appeared
             //a=97
             for(i=1,j=1;i<30;i++)
             {
                 if(hash[i])//have this character
                 {
                     node[j].weight=hash[i];//creat a node
                     node[j].parent=node[j].left=node[j].right=0;//inatialize
                     j++;
                 }
             }
             j--;//because the last j we plused didn't use
             for(i=j+1;i<2*j;i++)//initialize 
                 node[i].weight=node[i].parent=node[i].left=node[i].right=0; 
             for(i=j+1;i<2*j;i++)
             {
                 int s1,s2;//two smallest weight,s1<s2
                 s1=s2=9999999;
                 int x1,x2;//the node number of s1,s2
                 for(k=1;k<i;k++)//finde the smallest two
                 {
                     if(node[k].weight<s1&&node[k].parent==0)
                     {//smaller than the smallest
                         s2=s1;
                         x2=x1;
                         s1=node[k].weight;
                         x1=k;
                     }
                     else if(node[k].weight<s2&&node[k].parent==0)
                     {//smaller than the second smallest
                          s2=node[k].weight;
                          x2=k;
                     }
                 }
                 //creat a new node,which is the parent of s1 and s2 and is the sum of two
                 node[i].left=x1;
                 node[i].right=x2;
                 node[x1].parent=i;
                 node[x2].parent=i;
                 node[i].weight=node[x1].weight+node[x2].weight;
             }
             int sum=0;//now let's calculate the sum!
             for(i=1;i<=j;i++)
             {
                 int cnt=0;//get the number of layer
                 k=i;
                 while(node[k].parent!=0)
                 {
                     k=node[k].parent;
                     cnt++;
                 }
                 sum+=cnt*node[i].weight;
             }
             if(j==1)//the huffman cant solve when you only have one number!
                 sum=node[1].weight;
             /*if you have interest you can use this to get the sum of huffman*/
             //cout<<sum<<endl;
             
             
             
             //now compare and get the result.finally!
             if(sum<=lim)
             cout<<"yes"<<endl;
             else
             cout<<"no"<<endl;
    }
    return 0;
}
                     
                 
         
                 
                 
        

that's it~

寒假第一个ac~纪念下~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值