usaco 1.3.1 mixing milk

1 篇文章 0 订阅

简单到爆的题,只是mark一下,第一次一次ac~

节操是神马?酸酸甜甜有点咸?

Mixing Milk

Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

PROGRAM NAME: milk

INPUT FORMAT

Line 1:Two integers, N and M. 
The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers' want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from. 
Lines 2 through M+1:The next M lines each contain two integers, Pi and Ai
Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges.
Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

SAMPLE INPUT (file milk.in)

100 5
5 20
9 40
3 10
8 80
6 30

OUTPUT FORMAT

A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

SAMPLE OUTPUT (file milk.out)

630


fine。。我承认它确实简单过头了一滴滴。。

/*
ID: wtff0411
PROG: milk
LANG: C++
*/
#include <iostream>
#include <fstream>
#include <string>
#include <cstring>
#include <vector>

using namespace std;



int main()
{
    freopen("milk.in","r",stdin);
    freopen("milk.out","w",stdout);
    int amount,n;
    int i;
    int price[1010];
    int res=0;
    int get=0;
    memset(price,0,sizeof(price));
    cin>>amount>>n;
    for(i=0;i<n;i++)
    {
        int a,b;
        cin>>a>>b;
        price[a]+=b;
    }
    for(i=0;i<=1000;i++)
    {
        if((amount-get)<price[i])
        {
            res+=(amount-get)*i;
            break;
        }
        res+=i*price[i];
        get+=price[i];
    }
    cout<<res<<endl;
    //system("pause");
    return 0;
}
    
    
    
    

TASK: milk
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 3048 KB]
   Test 2: TEST OK [0.000 secs, 3048 KB]
   Test 3: TEST OK [0.000 secs, 3048 KB]
   Test 4: TEST OK [0.000 secs, 3048 KB]
   Test 5: TEST OK [0.011 secs, 3048 KB]
   Test 6: TEST OK [0.022 secs, 3048 KB]
   Test 7: TEST OK [0.011 secs, 3048 KB]
   Test 8: TEST OK [0.022 secs, 3048 KB]

All tests OK.

YOUR PROGRAM ('milk') WORKED FIRST TIME! That's fantastic -- and a rare thing. Please accept these special automated congratulations.


嘿嘿~(节操啊混蛋)

顺便,看题时居然把sample算错了。。不知道为什么眼瞎脑残一直去算9 40 那组了。结果不管了直接码题,运行发现和sample一样……才发现是我神经了……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值