Terrible Sets POJ - 2082

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
   

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

题意简述:
        紧贴x轴有一些互相挨着的矩形,给定每个矩形的长宽,问他们可以形成的最大矩形面见是多少?

思路:
     用堆栈来做,将矩形入栈,保持栈中的元素高度递增,如果即将入栈的高度dd.h比栈顶元素的高度lasth小,则退栈。一直退到可以保持栈顶元素高度递增的那个元素x,在退栈的过程中统计由lasts至x之间可以形成的最大矩形面积S,记录由lasth至x之间总宽度totalw,在弹出这些元素之后再向栈中压入一个高度为dd.h,宽为totalw+dd.w的矩形,然后继续读入下一个矩形。最后栈中元素一定是高度递增的,扫描一遍就可以了。

#include <iostream>
#include <stack>
#include <cstdio>
#include <algorithm>
using namespace std;

struct rec{
	int w;   //矩形的宽 
	int h;   //矩形的高 
}dd;

int main(){
	int n,ans,lasth,totalw,curarea;

	while(scanf("%d",&n)&&n!=-1){
		ans = 0;
		stack<rec>s;   //定义一个空栈
		lasth = 0;
		for(int i = 0;i < n;i++){
			scanf("%d %d",&dd.w,&dd.h);
			if(dd.h>=lasth){
				s.push(dd);   //进栈 
			}
			else{
			  totalw = 0;  //总宽 
			  curarea = 0; // 当前总面积 
			  while(!s.empty()&&s.top().h>dd.h){
			  	totalw+=s.top().w;  //没加dd.h 
			  	curarea = totalw*s.top().h; //栈里的矩形的h是递增的,pop出来的h是递减的; 
			  	if(curarea>ans) ans = curarea;
			  	s.pop(); 
			  }	
				dd.w +=totalw;
				s.push(dd); 
			} 
			lasth = dd.h;
		} 
		totalw = 0;
		curarea = 0;
		while(!s.empty()){
			totalw += s.top().w;
			curarea = totalw*s.top().h;
			if(curarea>ans) ans = curarea;
			s.pop();
		}
		printf("%d\n",ans);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值